1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Truck making a squealing noise

Discussion in '1st Gen. Tacomas (1995-2004)' started by dcmh, Jan 4, 2010.

  1. Jan 4, 2010 at 2:18 PM
    #1
    dcmh

    dcmh [OP] New Member

    Joined:
    Jan 4, 2010
    Member:
    #28752
    Messages:
    3
    Gender:
    Male
    Vehicle:
    Tacoma
    My 2004 Tacoma is making a squealing noise when when let up off the accelerator but is not consistent. I had the truck at the dealer today but they can't figure it out. Only thing that I had done 2 months ago was replace water pump and timing belt which they checked today and everything was fine.

    Any thoughts appreciated.

     
  2. Jan 4, 2010 at 2:21 PM
    #2
    Justin723

    Justin723 Dont judge me

    Joined:
    May 24, 2009
    Member:
    #17577
    Messages:
    524
    Gender:
    Male
    First Name:
    Justin
    Phoenix AZ
    Vehicle:
    01 Tacoma SR5
    Performance- bored .20 over, Doug Thorely Headers, Magnaflow Exhaust, and K&N cold air intake. Exterior- 7 inch lift, ARB compressor, high pinion 4.88 with ARB locker, 4.88 open diff in the rear, PIAA 520 series lights up front, and 36 inch fire stick. Interior- 2 10inch JL W1 subs, Alpine MRX-V70 amp, Alpine type R SPR 17C 6x6 speaker in the back, Focal 165 VR with crossover tweeter up front, Cobra LTD CB, and Weather Tech floor mats.
    Does it do it when your pushing the accelerator as well?
     
  3. Jan 4, 2010 at 3:25 PM
    #3
    dcmh

    dcmh [OP] New Member

    Joined:
    Jan 4, 2010
    Member:
    #28752
    Messages:
    3
    Gender:
    Male
    Vehicle:
    Tacoma
    Sometimes, but very consistent.
     
  4. Jan 4, 2010 at 3:30 PM
    #4
    Afwrestler1986

    Afwrestler1986 Well-Known Member

    Joined:
    May 20, 2008
    Member:
    #6768
    Messages:
    3,662
    Gender:
    Male
    First Name:
    Matt
    Johnstown, NY
    Vehicle:
    01 trd 4X4 ex cab manual
    Gray wire, Some lights in the bed area, and some character marks throughout.
    Check all of you belts. Don't just look at them, feel the inside and make sure they are not starting to get a "glassy" feel to them.
     
  5. Jan 4, 2010 at 9:05 PM
    #5
    2004Taco

    2004Taco Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    I had the same problem and it wasnt the belts. (Search for my thread).

    The only thing that i did to my truck before it made a squealing noise was a new power streering pump and a new muffler. It wasnt the belts, and it wasnt the muffler.
    Someone told me to check my vaccum lines, I did. I also was tweaking underneith my truck and sprayed some WD40 on things that might have made that noise. Now i dont even hear it.
    Try doing that.
     
To Top