1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

two TSBs in one day

Discussion in '2nd Gen. Tacomas (2005-2015)' started by cspcrx, Apr 26, 2010.

  1. Apr 26, 2010 at 12:31 PM
    #1
    cspcrx

    cspcrx [OP] Well-Known Member

    Joined:
    Aug 24, 2009
    Member:
    #21686
    Messages:
    98
    Gender:
    Male
    Vehicle:
    09 PreRunner Sport TRD
    Complained once about our sub making a funny sound and told them about the TSB. They said it was that we had the bass set on 2 and not zero. Set it to zero and still did the same thing. So they order a new amp for the sub.

    Complained about the ride when I towed even called Toyota about it and got a Ref number but they wouldnt fix it. Now with updated TSB to include 09s and pics to show how much to truck was squating they said ok.

    So last Friday they did the amp and rear springs. That was like pulling teeth.

    I know some have said the ride is harsh with the new 4 leaf springs. But to me it actually feels balanced. Before the front felt way firmer then the rear. I noticed when I would go over speed bumps. Now it feels more balanced.

    Hopefully the fixes will take care of things for good.

    Otherwise we are happy with the truck thus far. Getting 22mpg and its a pleasure to drive.
     
To Top