1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Uni Ball Creek/Pop Noise

Discussion in 'Technical Chat' started by bigtaco06, Dec 20, 2013.

  1. Dec 20, 2013 at 1:03 PM
    #1
    bigtaco06

    bigtaco06 [OP] Well-Known Member

    Joined:
    Jul 20, 2009
    Member:
    #19891
    Messages:
    536
    Gender:
    Male
    First Name:
    Jared
    Nor-Cal
    Vehicle:
    13 TRD OR DBCB SB
    Floor mats, shorty antenna, brute force hybrid front bumper, ICON stage 3, method double standards, 285/75/16 KM2's, cool stickers
    2013 Tacoma trd OR db cab 4x4
    ICON stage 3 w/tubular UCAs



    On Tuesday a buddy and I installed an Icon stage 3 kit w/ tube UCAs on my truck. The initial install/alignemnt went well. But yesterday my front passenger side developed a pop/creek sound. It only does it when I have the steering wheel cranked between 1/4 and full lock to the left while moving. It is very strange because it doesn't do it when I lock my wheel to side to side while stopped nor when the suspension flexes. The noise is not consistant and it wont happen every time my truck is in that condition. I know uni balls can be noisy but is a creeky pop normal? It sounds almost like it's in a bind and it releases. I have tried to retorque everything and there are no signs of damage. I have played in the dirt since the install but have thrown nothing at it that a uni ball can't handle.
     
  2. Jun 24, 2014 at 6:48 PM
    #2
    ProForce

    ProForce Thin Blue Line

    Joined:
    Oct 12, 2009
    Member:
    #24205
    Messages:
    5,410
    Gender:
    Male
    First Name:
    Anthony
    SoCal-Ontario
    Vehicle:
    09 MGM TRD Sport DCSB 4.0 Auto 2wd
    Too many to list. See build page. Link in signature
    did you ever get this resolved? I am having a very similar pop/creek noise after lift and at almost full lock. same symptoms
     
  3. Jun 26, 2014 at 8:01 PM
    #3
    JJ04TACO

    JJ04TACO Well-Known Member

    Joined:
    Oct 12, 2013
    Member:
    #114311
    Messages:
    267
    Gender:
    Male
    First Name:
    Jim
    Dallas
    Vehicle:
    04 TRD
    Toytec BOSS lift, Camburg Uniball UCA's, Scangauge II Uniden Bearcat 880 w/ 3' Firestick on CBI antenna mount
    My Camburg uniball UCA's do this as well. Only on the driver side though when steering left and right. I have no up down noises. I replaced half shafts, which required unbolting the spindle and articulating the UCA upward and out of the way. I lubed it and articulated it all over the place and the noise went away...for about two weeks. Now its back. I just clean it and lube it with dry lube and deal with it. :)
     
  4. Jul 19, 2014 at 6:32 AM
    #4
    bigtaco06

    bigtaco06 [OP] Well-Known Member

    Joined:
    Jul 20, 2009
    Member:
    #19891
    Messages:
    536
    Gender:
    Male
    First Name:
    Jared
    Nor-Cal
    Vehicle:
    13 TRD OR DBCB SB
    Floor mats, shorty antenna, brute force hybrid front bumper, ICON stage 3, method double standards, 285/75/16 KM2's, cool stickers
    After retorquing everything to spec, I turned up the radio and I never heard the noise agian.

    -Sorry for such a long response time I'm in Afghanistan.
     
  5. Jul 20, 2014 at 7:32 AM
    #5
    JJ04TACO

    JJ04TACO Well-Known Member

    Joined:
    Oct 12, 2013
    Member:
    #114311
    Messages:
    267
    Gender:
    Male
    First Name:
    Jim
    Dallas
    Vehicle:
    04 TRD
    Toytec BOSS lift, Camburg Uniball UCA's, Scangauge II Uniden Bearcat 880 w/ 3' Firestick on CBI antenna mount
    I've had a few friends there over the years. Internet access is not what it is here. Stay safe, and good call on the radio...
     
To Top