1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Update with new question: 04 V6 02 Sensor part number confusion

Discussion in '1st Gen. Tacomas (1995-2004)' started by mikegli, Aug 18, 2014.

  1. Aug 18, 2014 at 2:48 PM
    #1
    mikegli

    mikegli [OP] Well-Known Member

    Joined:
    Dec 8, 2009
    Member:
    #27222
    Messages:
    67
    Gender:
    Male
    Orlando
    Vehicle:
    04 Tacoma TRD
    From the passenger side, I can locate the upstream and downstream, but can't find the 2nd upstream. Any pointers?

    Thank you,


    ****EDIT*****

    Now I'm looking at part numbers. Member Alderleet posted a great DIY and indicated the part number is Part #234-4162, but when I search through RockAuto, the Denso part number is Part #2349001. Is one a Toyota part number and the other is Denso number? I understand them to make the OEM, but there is a significant price difference between the two.

    Thanks,
     
    Last edited: Aug 18, 2014
  2. Aug 18, 2014 at 3:39 PM
    #2
    mikegli

    mikegli [OP] Well-Known Member

    Joined:
    Dec 8, 2009
    Member:
    #27222
    Messages:
    67
    Gender:
    Male
    Orlando
    Vehicle:
    04 Tacoma TRD
    Or am I looking for something that doesn't exist? Does this truck only have 2?
     
  3. Aug 18, 2014 at 3:46 PM
    #3
    jspansel

    jspansel Just duct tape it

    Joined:
    Jul 19, 2013
    Member:
    #108591
    Messages:
    434
    Gender:
    Male
    First Name:
    Jay
    Central OR
    Vehicle:
    01 V6 Xtra Cab Tacoma, 5 Speed, 4x4, Lifted
    5100s front at 2.5" with Moog replacement springs, 5100s in rear with 2" Wheeler's AAL
    Believe only those 2...
     
  4. Aug 18, 2014 at 4:07 PM
    #4
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,343
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
    My 96 (3.4) only had 2
     
  5. Aug 18, 2014 at 4:32 PM
    #5
    mikegli

    mikegli [OP] Well-Known Member

    Joined:
    Dec 8, 2009
    Member:
    #27222
    Messages:
    67
    Gender:
    Male
    Orlando
    Vehicle:
    04 Tacoma TRD
    Thanks, guys, I had it in my head there were 4, but even downstream I only see 1.
    I'll see if I can post something up this weekend when I do the work.
     
  6. Aug 22, 2014 at 6:10 PM
    #6
    mikegli

    mikegli [OP] Well-Known Member

    Joined:
    Dec 8, 2009
    Member:
    #27222
    Messages:
    67
    Gender:
    Male
    Orlando
    Vehicle:
    04 Tacoma TRD
    Got it sorted out. The nuts came off pretty easy after a few days of PB Blaster but they weren't fit to be used again so I picked up replacements.
     

Products Discussed in

To Top