1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Updated profile; now the questions

Discussion in 'New Members' started by acolsch, Dec 21, 2010.

  1. Dec 21, 2010 at 8:54 PM
    #1
    acolsch

    acolsch [OP] Member

    Joined:
    Nov 20, 2010
    Member:
    #46477
    Messages:
    17
    Gender:
    Male
    First Name:
    Andy
    McGuire AFB, NJ
    Vehicle:
    05 Tacoma
    DVD Player
    Profile is updated-- here come the questions

    The 05 Tacoma is at 95K. I've read through multiple threads about flushing the tanny. Here's my list of homegrown MX for the pending 100K service (do it myself). Please feel free to tell me where I'm wrong and what I should be concerned with.

    - Original serpentine belt - need to replace
    - Change out diff fluid front and rear
    - Plugs changed at 65K - leave alone
    - Not sure about the anti-freeze - flush?
    - Air filter changed at 65K - almost time
    - New battery 1 month ago - (GTG) Good to Go
    - 4WD finally figured out where the zerts were 5K ago - lubed

    What am I missing?
     
  2. Dec 21, 2010 at 8:56 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    103,904
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    I would change the plugs too. You have that listed as "leave alone"...
     
  3. Dec 21, 2010 at 9:12 PM
    #3
    acolsch

    acolsch [OP] Member

    Joined:
    Nov 20, 2010
    Member:
    #46477
    Messages:
    17
    Gender:
    Male
    First Name:
    Andy
    McGuire AFB, NJ
    Vehicle:
    05 Tacoma
    DVD Player
    Really.

    Funny thing, if you look at my avatar you can see the red Corvette. I used to have to change the pugs every 10K on that thing - ugly. some burnt, some wet. I think I went 60K on the 4runner without changing - still beautiful. I changed the 05 Tacoma's at 60K and they looked as if they had another 30K easy.
    Worried about the 04 Tacoma more. I've been reading up on the dual pin plug requirement. didn't believe it until I saw the sticker.
    The 05 pulled out Denso's and replaced with Denso's. Do you think 35K it's time to change or just good precaution?
     
To Top