1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

URD MAF Sensor Calibrator

Discussion in 'Performance and Tuning' started by AZsurfer13, Dec 29, 2007.

  1. AZsurfer13

    AZsurfer13 [OP] Well-Known Member

    Joined:
    Dec 15, 2007
    Member:
    #3845
    Messages:
    64
    Houston, Texas
    Vehicle:
    07 Regular Cab Tacoma
    Total Chaos 3" Coil Over and Control Arms, 15" American Racing Mojave's, 31" BFG A/T, Doug Thorley Ceramic Coated Header, Magnaflow Cat Back Exhaust, AFE Stage 2 Cold Air Intake, 20% Tint. (All work done by SDHQ Offroad, www.sdhqoffroad.com)
    Does anyone have this on their truck? After putting performance parts on my truck I think the MAF sensor is causing my check engine light to come on. Does this device turn that light off?
     
  2. jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Staff Member

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    26,856
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    i dont believe it will remove the CEL. the maf cal deals w/ the air/fuel ratio after adding mods to get the best performance out of them. the CEL from a MAF could be caused by oil from an aftermarket intake filter. some people have said that you can clean the MAF and that may help.
     
  3. Spyder327

    Spyder327 Well-Known Member

    Joined:
    May 25, 2007
    Member:
    #1677
    Messages:
    204
    Phoenix, AZ
    Vehicle:
    2005 X-Runner
    Aquamist 2D meth/water injection kit, URD Exhaust, DT Long Tube Headers, Hood Struts, and lots of other miscellaneous stuff...
    You have the CEL because you have the doug thorley long tube headers. They eliminate the front cats which are monitored by the rear O2 sensors. It threw the light because the sensors realized the cats are no longer in place. If you want the CEL gone, you need this:

    http://www.urdusa.com/product_info.php?cPath=66_72&products_id=1260518515

    The MAF calibrator is instead for tuning to get the correct air/fuel ratio to gain the most power from your mods, it is totally separate from your CEL problem, but it can be found here:

    http://www.urdusa.com/product_info.php?cPath=66_72&products_id=1260198051

    (this is under the assumption that you in fact have the long tube version of the headers, and that your CEL code should be P0420)
     
  4. Spyder327

    Spyder327 Well-Known Member

    Joined:
    May 25, 2007
    Member:
    #1677
    Messages:
    204
    Phoenix, AZ
    Vehicle:
    2005 X-Runner
    Aquamist 2D meth/water injection kit, URD Exhaust, DT Long Tube Headers, Hood Struts, and lots of other miscellaneous stuff...
    Crap, just realized you have a 4cyl and not a 6.... I'm not sure on the exhaust routing and what not with that one. Go get your code pulled and i can help more.
     
  5. My68ur8trd

    My68ur8trd Well-Known Member Vendor

    Joined:
    Oct 7, 2007
    Member:
    #2961
    Messages:
    1,532
    Gender:
    Male
    First Name:
    Justin
    Williamsburg, VA
    Vehicle:
    2007 TRD OR Dcab 4x4
    URD Catback | TRD CAI | TRD S/C | APR X-1 | DTLT | APR 2.85" Pulley |Fabtech 6" | Icon C/O | Alcan Leafs | 33 Grabber AT2 | 17" XD Addicts
    I made the same post a deleted it :D

    So used to XRU with everyone 4.0

    Justin
     
  6. jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Staff Member

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    26,856
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    ahh...good point...i didnt even think about the headers...but yes, if they took the front cats out and u didnt use any 02 simulators, then it will have a CEL. good catch XR guys
     
  7. AZsurfer13

    AZsurfer13 [OP] Well-Known Member

    Joined:
    Dec 15, 2007
    Member:
    #3845
    Messages:
    64
    Houston, Texas
    Vehicle:
    07 Regular Cab Tacoma
    Total Chaos 3" Coil Over and Control Arms, 15" American Racing Mojave's, 31" BFG A/T, Doug Thorley Ceramic Coated Header, Magnaflow Cat Back Exhaust, AFE Stage 2 Cold Air Intake, 20% Tint. (All work done by SDHQ Offroad, www.sdhqoffroad.com)

    The front cats and rear O2 sensor are still there. Will I most likely still need that sensor though? I reset it over night last night and it hasnt turned on today, but there is probably a mile limit till it turns back on.
     
  8. jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Staff Member

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    26,856
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    if u have ur front cats and both sets of sensors, then that shouldnt be it. have you recently oiled the afe filter? or did you do everything at once and it turned on?
     
  9. AZsurfer13

    AZsurfer13 [OP] Well-Known Member

    Joined:
    Dec 15, 2007
    Member:
    #3845
    Messages:
    64
    Houston, Texas
    Vehicle:
    07 Regular Cab Tacoma
    Total Chaos 3" Coil Over and Control Arms, 15" American Racing Mojave's, 31" BFG A/T, Doug Thorley Ceramic Coated Header, Magnaflow Cat Back Exhaust, AFE Stage 2 Cold Air Intake, 20% Tint. (All work done by SDHQ Offroad, www.sdhqoffroad.com)
    Direct quote from afe website:
    "Whenever we design a new intake tube, the biggest challenge is the factory Mass Airflow Sensor. You just can’t place the MAF sensor any place. The modern MAF sensor is sensitive to changes in air speed and volume. Slight changes can improve performance or it can trigger the Check Engine Light (CEL). We design our tube so that the factory MAF sensor is positioned in just the right place so that you get the best performance possible without triggering the CEL."

    I do not think the filter is the problem, haha, its quite irritating. Plus Thorley was closed today so I couldn't get a hold of them.
     
  10. jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Staff Member

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    26,856
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    right...thats referring to actually getting air to the MAF...thats not referring to oil sucking in from the filter and getting on the sensor
     
  11. AZsurfer13

    AZsurfer13 [OP] Well-Known Member

    Joined:
    Dec 15, 2007
    Member:
    #3845
    Messages:
    64
    Houston, Texas
    Vehicle:
    07 Regular Cab Tacoma
    Total Chaos 3" Coil Over and Control Arms, 15" American Racing Mojave's, 31" BFG A/T, Doug Thorley Ceramic Coated Header, Magnaflow Cat Back Exhaust, AFE Stage 2 Cold Air Intake, 20% Tint. (All work done by SDHQ Offroad, www.sdhqoffroad.com)
    The filter is a dry filter though.
     
  12. dabighi

    dabighi Well-Known Member

    Joined:
    Oct 8, 2007
    Member:
    #2978
    Messages:
    170
    whats the deeal with the MAF calibrator. I know what it does, but does it recal automatically or do you have to dyno or wideband it to get it to work? so anything that you guys can give me that would be great.
     
  13. jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Staff Member

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    26,856
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    ur right...i just looked at ur pics and u have the grey filter...definately the dry one...u got me then man...i have no idea. have u had the codes read on it yet? if not, go to autozone/advanced auto and they'll read them and give u a print out for free
     
  14. AZsurfer13

    AZsurfer13 [OP] Well-Known Member

    Joined:
    Dec 15, 2007
    Member:
    #3845
    Messages:
    64
    Houston, Texas
    Vehicle:
    07 Regular Cab Tacoma
    Total Chaos 3" Coil Over and Control Arms, 15" American Racing Mojave's, 31" BFG A/T, Doug Thorley Ceramic Coated Header, Magnaflow Cat Back Exhaust, AFE Stage 2 Cold Air Intake, 20% Tint. (All work done by SDHQ Offroad, www.sdhqoffroad.com)
    Yeah me either, it sucks. I'm hoping it was just a fluke and everything is good after reseting it. :pray:
     
  15. Spyder327

    Spyder327 Well-Known Member

    Joined:
    May 25, 2007
    Member:
    #1677
    Messages:
    204
    Phoenix, AZ
    Vehicle:
    2005 X-Runner
    Aquamist 2D meth/water injection kit, URD Exhaust, DT Long Tube Headers, Hood Struts, and lots of other miscellaneous stuff...
    You either need to tune it via dyno or feedback from a wideband sensor.

    You need to go get the code read from somewhere and let us know so we can help you. What was the last thing you altered on the truck before the CEL came on?
     
  16. AZsurfer13

    AZsurfer13 [OP] Well-Known Member

    Joined:
    Dec 15, 2007
    Member:
    #3845
    Messages:
    64
    Houston, Texas
    Vehicle:
    07 Regular Cab Tacoma
    Total Chaos 3" Coil Over and Control Arms, 15" American Racing Mojave's, 31" BFG A/T, Doug Thorley Ceramic Coated Header, Magnaflow Cat Back Exhaust, AFE Stage 2 Cold Air Intake, 20% Tint. (All work done by SDHQ Offroad, www.sdhqoffroad.com)
    That last thing that was put on were the Headers.
     
  17. Spyder327

    Spyder327 Well-Known Member

    Joined:
    May 25, 2007
    Member:
    #1677
    Messages:
    204
    Phoenix, AZ
    Vehicle:
    2005 X-Runner
    Aquamist 2D meth/water injection kit, URD Exhaust, DT Long Tube Headers, Hood Struts, and lots of other miscellaneous stuff...
    Best thing to do then is retorque the headers and check for exhaust leaks.
     
  18. AZsurfer13

    AZsurfer13 [OP] Well-Known Member

    Joined:
    Dec 15, 2007
    Member:
    #3845
    Messages:
    64
    Houston, Texas
    Vehicle:
    07 Regular Cab Tacoma
    Total Chaos 3" Coil Over and Control Arms, 15" American Racing Mojave's, 31" BFG A/T, Doug Thorley Ceramic Coated Header, Magnaflow Cat Back Exhaust, AFE Stage 2 Cold Air Intake, 20% Tint. (All work done by SDHQ Offroad, www.sdhqoffroad.com)
    haha just had it retorqued yesterday. After the retorque is when it cam on, about 15 miles later. Ive gone a 100 miles after reseting it and still no light so Im thinking it was just an error. What is the mile limit to trip the light on tacomas?
     
  19. Spyder327

    Spyder327 Well-Known Member

    Joined:
    May 25, 2007
    Member:
    #1677
    Messages:
    204
    Phoenix, AZ
    Vehicle:
    2005 X-Runner
    Aquamist 2D meth/water injection kit, URD Exhaust, DT Long Tube Headers, Hood Struts, and lots of other miscellaneous stuff...
    typically 30-40 miles. If it's staying off then you're good to go. If it comes back on, get the code checked.
     
  20. AZsurfer13

    AZsurfer13 [OP] Well-Known Member

    Joined:
    Dec 15, 2007
    Member:
    #3845
    Messages:
    64
    Houston, Texas
    Vehicle:
    07 Regular Cab Tacoma
    Total Chaos 3" Coil Over and Control Arms, 15" American Racing Mojave's, 31" BFG A/T, Doug Thorley Ceramic Coated Header, Magnaflow Cat Back Exhaust, AFE Stage 2 Cold Air Intake, 20% Tint. (All work done by SDHQ Offroad, www.sdhqoffroad.com)
    So after 140 miles the CEL comes back on, but after about 40 miles it goes back off. Got a hold of Thorley and they said it is most likely flakes from the ceramic coating process. But the headers and intake are definitly not causing the light to come on. So thats good news I guess. Thanks for all the help though or at least concern.
     
To Top