1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

USA Spec PA12TOY damaged ipod

Discussion in 'Audio & Video' started by simon2505, Mar 22, 2008.

  1. Mar 22, 2008 at 2:37 PM
    #1
    simon2505

    simon2505 [OP] Member

    Joined:
    Jun 27, 2007
    Member:
    #1926
    Messages:
    8
    Hi everyone ...
    Has anyone had its ipod damaged when connecting it to the USA Spec PA12TOY interface? this has just happened to me. I used to connect the ipod to the interface not worrying about when, I mean .. I connected it while the truck was on or off but I think that the best way to do it is when the truck is on; why because when my ipod was damaged when I plugged it on interface and immediately hit the ignition.. I guess that wasn’t a very good idea because the interface was initiating the ipod (when the ipod flicks) and a sudden change on the voltage may have burned it. Now my ipod doesn’t start and I’m a little worry about buying a new one and when I connect it burn another ipod.:confused:
     
  2. Mar 22, 2008 at 3:19 PM
    #2
    maverick491

    maverick491 Towing Guru

    Joined:
    Apr 30, 2007
    Member:
    #1462
    Messages:
    1,077
    Gender:
    Male
    South Jersey
    Vehicle:
    07 4x4 Access Cab, TRD off road, 6 cyl, 6 spd
    Activator III brake controller, Extang Fulltilt toneau, Factory bed mat, Extra D-rings in the bed, 2ndary air filter removed, Garmin Ique GPS, Eco-2, AFE Pro Dry-s filter, USASPEC PA12-toy, Pioneer 3-way speakers, SG II on Blendmount, Gulf States Alarm added.
    Have not heard of this happening, and I've had three different model Ipods connected to mine, and have already had it connected while starting the truck, connected then immediately started the truck or connected it after the truck was already running.

    This may seem like a stupid question, but have you tried a hard reset of the IPOD?

    Slide the hold switch to hold and then off again and then hold the Menu and Center buttons for 6-10 seconds.
     
  3. Mar 22, 2008 at 3:41 PM
    #3
    simon2505

    simon2505 [OP] Member

    Joined:
    Jun 27, 2007
    Member:
    #1926
    Messages:
    8
    Hi Maverick,
    Yep the USA SPEC interface is owesome, I have had it for almost a year and I'm sure that I have donne the same connection procedure many times. My post was to check if someone else have experience something similar. The ipod is completly dead, the screen on the ipod is black no matter what I try :D ...
     
  4. Mar 22, 2008 at 4:17 PM
    #4
    maverick491

    maverick491 Towing Guru

    Joined:
    Apr 30, 2007
    Member:
    #1462
    Messages:
    1,077
    Gender:
    Male
    South Jersey
    Vehicle:
    07 4x4 Access Cab, TRD off road, 6 cyl, 6 spd
    Activator III brake controller, Extang Fulltilt toneau, Factory bed mat, Extra D-rings in the bed, 2ndary air filter removed, Garmin Ique GPS, Eco-2, AFE Pro Dry-s filter, USASPEC PA12-toy, Pioneer 3-way speakers, SG II on Blendmount, Gulf States Alarm added.
    Do you have an actual "Apple store" local to you, like not a best buy, or circuit city, but an Apple store. I understand that they are pretty good about customer satisfaction and such, so maybe go in there and play dumb and see if the can help you out?

    To answer your orriginal question, in my year or so on this forum, I've not heard of another incident like your. Sorry man.
     
  5. Mar 31, 2008 at 12:58 PM
    #5
    dusty1313

    dusty1313 New Member

    Joined:
    Jan 31, 2008
    Member:
    #4507
    Messages:
    3
    Vehicle:
    PreRunner SR5
    back up camera
    Bought My USA Spec PA-12 about 2 months ago and have not had any problems with it yet. Its is a very tight fit unplugging and plugging. I'm still trying to figure out how to control the ipod for searching and to get the text info at the same time. Maybe it doesn't do that no matter how you set the switches.
     
  6. Apr 15, 2008 at 6:49 PM
    #6
    simon2505

    simon2505 [OP] Member

    Joined:
    Jun 27, 2007
    Member:
    #1926
    Messages:
    8
    Good news…. The ipod is back!!!, apparently the ipod stayed in an deep hangup that required the battery to go completely dead, after a week and half I connected the ipod again to my computer and voila! it started. Just wanted to make some justice on both the ipod and the usa spec interface.
     
To Top