1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Ut-Oh Supercharger problem

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Joe B, Mar 27, 2009.

  1. Mar 27, 2009 at 1:23 PM
    #1
    Joe B

    Joe B [OP] Well-Known Member

    Joined:
    Oct 27, 2008
    Member:
    #10290
    Messages:
    806
    Just dropped off my truck and got a loaner.
    Coincidentally,I had the spring TSB done yesterday and when I picked up the truck,I had a slight problem starting it.
    Took longer than usual to start.When it started I figured while I'm here at the dealer,let me start it again and see what happens.
    When I shut down I hurt this metallic type sound just at the end when the engine goes off.Two metallic sounds..Started it again and had the same sound.Two metallic sounds every time.
    Went back inside and told the service rep.He came out and heard the sound and said the guy that installed the SC and knows more than him about them went home and to come back Monday if it continues.
    Well,I didn't want to wait till Monday.Same sounds today.I just dropped it off.I'm guess but it sounds like a bearing issue.
    The dealer will call TRD,then probably take the unit apart and send pics to TRD.In any case it's under warranty so I'll have a loaner till it's repaired or better yet,I want it replaced.
    I have a feeling the tech that did the springs had some fun with the springs test drive.Even if that's the case,the unit still shouldn't have the issue.
    The truck ran fine along with the supercharger.Just a noise when the engine is turned off.

    Anybody want to guess what the problem is and we'll see who wins.:)
     
  2. Mar 27, 2009 at 1:32 PM
    #2
    David Tarantino

    David Tarantino Well-Known Member

    Joined:
    Jun 20, 2008
    Member:
    #7428
    Messages:
    6,123
    Gender:
    Male
    N.J.
    Vehicle:
    08 tacoma
    i have the same feeling about that someone had some fun
    what dealer
     
  3. Mar 27, 2009 at 1:35 PM
    #3
    Joe B

    Joe B [OP] Well-Known Member

    Joined:
    Oct 27, 2008
    Member:
    #10290
    Messages:
    806
    East Coast.
    Even if a tech beat on it a bit during the springs test ride,the SC should have been able to take it.
    It's not like it's been beat on for weeks.
    Who knows?:eek:
     
  4. Mar 27, 2009 at 2:11 PM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,148
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    X2. The SC should take alot of abuse. TRD tested the supercharger at WOT for 250 hours for a duability test. Toyota didnt want it if it wouldnt cause any harm to the engine. I bet its the rear nearings, though. The new SC's seem to have this issue. No biggie. You should get a new SC out of it.
     
  5. Mar 27, 2009 at 2:43 PM
    #5
    Joe B

    Joe B [OP] Well-Known Member

    Joined:
    Oct 27, 2008
    Member:
    #10290
    Messages:
    806
    I just called TRD and told them what happened and asked if there was any issue with the '09 model being it's new.I think the watercooling is different on the '09 model but I may be wrong.
    They gave a me a tech girl and she said there hasn't been an issue with the 09.They wouldn't say there was anyway but I figured I'd take a shot.
    The SC runs fine.Just that noise when the engine shuts off.
    TRD says they send a field person out to check the situation.She just got my name and address and didn't ask about any dealer info.I guess they'll wait for the dealer to call.
    I asked in a case like this can she guesstimate how long this will all take.She really didn't know but said probably a week.
    I have a loaner so I'm sure the dealer will want this done pretty quickly.
    I'll keep everyone posted.
     
  6. Apr 5, 2009 at 8:34 AM
    #6
    2009tacomav6

    2009tacomav6 Well-Known Member

    Joined:
    Dec 6, 2008
    Member:
    #11323
    Messages:
    385
    Gender:
    Male
    phx AZ
    Vehicle:
    2012 4x4
    TRD SC TRD Cat Back KMC 17x9 Addicts
    The only thing that I know of being different in the 09 model is the fit kit. I do not beleive the SC itself is different.
     
  7. Apr 5, 2009 at 8:38 AM
    #7
    DanGer

    DanGer Avatar approved by 98tacomav6

    Joined:
    Jun 7, 2008
    Member:
    #7155
    Messages:
    5,494
    Gender:
    Male
    Northern Virginia & Blacksburg
    Vehicle:
    07 Base 4Cyl 4x4 Manual
    White Head Light mod, White shorty antennae, Doug Thorley Long Tube headers, AFE Drop in air filter, Secondary Air Filter Removed,
    hey did you call toyota directly and get a case number? MAy be useful in the future if they try pulling anything
     
  8. Apr 5, 2009 at 8:41 AM
    #8
    Joe B

    Joe B [OP] Well-Known Member

    Joined:
    Oct 27, 2008
    Member:
    #10290
    Messages:
    806
    Nope.
    Different part#

    Internally maybe but the coolant tank,exhaust manifolds are different and some engine sensors in different places.
     
  9. Apr 8, 2009 at 2:18 AM
    #9
    jhershman27

    jhershman27 jhershman27

    Joined:
    Apr 7, 2009
    Member:
    #15662
    Messages:
    2
    Gender:
    Male
    First Name:
    James
    Salt Lake City, UT
    Vehicle:
    09' Supercharged/Lifted Tacoma
    Pending: TRD Supercharger, TRD Exhaust, TRD Quickshifter, ARB Bullbar w/ Warn 9000 Winch, Billstein 5100 Struts & Shocks, 2" Leaf Blocks, 2.8" URD Pulley

    So I've just picked up a new 09 Access Cab, and want the dealersip to put on the supercharger and exhaust. I would like to call TRD and ask them a couple compatablity questions though. Have their number?
     
  10. Apr 8, 2009 at 3:42 AM
    #10
    cole47

    cole47 Well-Known Member

    Joined:
    Oct 31, 2008
    Member:
    #10400
    Messages:
    1,126
    Gender:
    Male
    First Name:
    Cole
    Hickory NC
    Vehicle:
    Ray of Sunshine
    lift, wheels, tires
    Mine messed up a while back. Not sure what the problem was they said something about the bearings?? Not real bright when it comes to these things, but i DID get a new one out of it.
     
  11. Apr 8, 2009 at 3:51 AM
    #11
    Joe B

    Joe B [OP] Well-Known Member

    Joined:
    Oct 27, 2008
    Member:
    #10290
    Messages:
    806
    1-800-688-5912
     
  12. Apr 27, 2009 at 7:34 PM
    #12
    2009tacomav6

    2009tacomav6 Well-Known Member

    Joined:
    Dec 6, 2008
    Member:
    #11323
    Messages:
    385
    Gender:
    Male
    phx AZ
    Vehicle:
    2012 4x4
    TRD SC TRD Cat Back KMC 17x9 Addicts
    I have the same noise... ugg
     
  13. Apr 27, 2009 at 7:39 PM
    #13
    06BLUEDBLSPORT

    06BLUEDBLSPORT Well-Known Member

    Joined:
    Apr 22, 2008
    Member:
    #6140
    Messages:
    4,070
    Gender:
    Male
    First Name:
    Colin
    Lubbock Texas
    Vehicle:
    12 Tundra DC SR5 4x4 5.7L
    True Dual Flowmaster 40 Series exhaust, Volant CAI, HIDs, Raptor series Side Steps, Weathertech Floorliners, OME 613 Shocks and Coils with Diff Drop, Rear Bilstein 5100 Shocks, ToyTec AAL, Fearless Fabrication Front Bumper
    Never leave a supercharged truck alone at a dealership. If i was you i would just stay there till there done or put a hidden camera in the truck (i know thats extreme but its not when it comes to 4 grand of supercharger) so if they did beat it I would know, thats just me
     
To Top