1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

vent stink after turning off a/c

Discussion in '1st Gen. Tacomas (1995-2004)' started by az40ss, Aug 15, 2008.

  1. Aug 15, 2008 at 7:24 AM
    #1
    az40ss

    az40ss [OP] Member

    Joined:
    Aug 15, 2008
    Member:
    #8549
    Messages:
    9
    chula vista
    Vehicle:
    05 double cab prerunner shortbed
    Each time after I turn off my a/c my truck cab STINKS!!! Is there an interior cab filter that can be replaced? or does anyone know what I may need to do to resolve this issue? thanks...
     
  2. Aug 15, 2008 at 8:06 AM
    #2
    91r100gs

    91r100gs Understand the Voice Within

    Joined:
    Apr 21, 2008
    Member:
    #6100
    Messages:
    655
    Gender:
    Male
    First Name:
    Dan
    Kansas City area
    Vehicle:
    '08 Impluse Red SR5 I-4
    Factory bed mat, TacomaWorld.com sticker, EGR In-Channel Vent Visors, AFE ProDryS drop in air filter
    Not sure if your 1st gen has a cabin air filter, if it does replace it. But do turn off your recirculate button(or Max a/c) before you shut off the engine and send a blast of fresh air through the system, that moldly/mildew smell will lessen. If that does not help, get a can of nicely scented LYSOL that says it kills germs. Turn on the system on recirculate with blower on 3 or 4 and spray and close the door for several minutes with doors and windows closed. Would recommend that you not be in vehicle while doing this and don't spare the LYSOL. Do this several times over several days and you will breath better. I am very allergic to mold/mildew and this really does help.


    Sorry for the long winded post. Hey Hey it is my 100th post:bananadance:
     
  3. Aug 15, 2008 at 8:15 AM
    #3
    Jester243

    Jester243 mod status????

    Joined:
    Jun 25, 2008
    Member:
    #7552
    Messages:
    9,996
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 Trail Premium 4Runner w/ KDSS
    same problem here as well if i get home and turn off the truck before turning off the a/c. The best solution is just to turn off the a/c and let the blower run for a few seconds prior to turning the truck off.

    -Dan
     
  4. Aug 15, 2008 at 4:45 PM
    #4
    mudjunkie

    mudjunkie Well-Known Member

    Joined:
    Jul 17, 2008
    Member:
    #7995
    Messages:
    212
    Gender:
    Male
    clearwater fl
    Vehicle:
    96 tacoma sx l
    header,short rack and pinion, heavy duty shocks, grill guard, flowmaster exhaust,pacesetter header without catalytic converter, one 10 inch xant sub with a mtx amp, off road lights,diamondplate tool box,rhinolined inside cab,ngk plugwires.
    i had this same issue i went to the auto store and purchased some stuff called ozium it worked great it literally eats the stink away i used one can over a period of three days and i have not had this problem since. its been about six months now.
     
  5. Aug 15, 2008 at 4:47 PM
    #5
    beastlytaco

    beastlytaco This is TW. One never knows what is a joke anymore

    Joined:
    Jun 30, 2008
    Member:
    #7660
    Messages:
    4,042
    Gender:
    Male
    First Name:
    Ian
    Vehicle:
    08 tacoma standard cab
    15% tinted back window, 25% on sides. Jardine catback exhaust system. horn modification, AFE pro dry S filter and secondary filter removed. All weather toyota tacoma mats.
    might want to check for dead animals. rats, cats etc. I had a dead squirll in my moms buick engine compartment several years ago. it smelled awful
     
  6. Aug 15, 2008 at 5:38 PM
    #6
    rick

    rick `

    Joined:
    Mar 1, 2007
    Member:
    #993
    Messages:
    2,489
    Gender:
    Male
    cabin air filter is located behind the glovebox. remove the glovebox door to replace it.
    and that ozium stuff is great.
     
  7. Aug 15, 2008 at 5:42 PM
    #7
    rick

    rick `

    Joined:
    Mar 1, 2007
    Member:
    #993
    Messages:
    2,489
    Gender:
    Male
    sorry. wrong generation
     
  8. Aug 15, 2008 at 5:42 PM
    #8
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
    There are no cabin filters in the 1st gens. Get something called Frigi-Fresh and spray that in the intake and follow the advice of the guys up above too.
     
  9. Aug 15, 2008 at 6:14 PM
    #9
    genxer36

    genxer36 Lord of Tomfoolery

    Joined:
    Nov 13, 2007
    Member:
    #3442
    Messages:
    10,581
    Gender:
    Male
    First Name:
    Sean
    Bethlehem,GA
    Tow package, XM Satellite radio, K & N Air filter, & Channel Vent Visors
    Its mold & mildew in your system. I had the same problem. The dealer does a cleaning that will take care of it. They spray a chemical through your a/c system. I had this done over a year ago & I think it was $40. My vehicle is 3 yrs old & I have only needed to have this done once so far.
     
To Top