1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Weird A/C Compressor Noise?

Discussion in '1st Gen. Tacomas (1995-2004)' started by JRA2000TL, Apr 2, 2010.

  1. Apr 2, 2010 at 9:51 AM
    #1
    JRA2000TL

    JRA2000TL [OP] Member

    Joined:
    Mar 24, 2010
    Member:
    #33873
    Messages:
    16
    Gender:
    Male
    Mobile, AL
    Vehicle:
    04 PreRunner SR5 TRD Xtra Cab V6
    Just noticed on my 04 that when I'm stopped at a light in drive with the a/c on, it makes a "bloop bloop bloop" type repititious noise when it kicks in. Is this normal? Heard the loudest when the truck is in gear. No noise under the hood. Any ideas?
     
  2. Apr 2, 2010 at 3:10 PM
    #2
    JRA2000TL

    JRA2000TL [OP] Member

    Joined:
    Mar 24, 2010
    Member:
    #33873
    Messages:
    16
    Gender:
    Male
    Mobile, AL
    Vehicle:
    04 PreRunner SR5 TRD Xtra Cab V6
    I looked at it more and so did my buddy at the oil change place. We thought it might be the timing belt tensioner thumping, but I got home with my stethoscope and put it to one of the bolts on the cover and that's not it.

    My fan looks kind of wobbly. The noise sounds almost as if the fan is bumping the shroud, but it's not. It's coming from that frontal area where the fan connects to the pulley at the engine. The loudest noise came from the a/c compressor only while in gear with the a/c compressor engaged. Are these things notorious for breaking on these? I also heard noise resonating from the oil pan. I REALLY hope this is not a rod knock. This truck is really pissing me off.

    I've had this truck a week and already have issues. I'm aggravated. This means the previous owner probably did 0 maintenance and now it's my problem. I bought a Toyota for reliability and it's not starting off well. I guess at 109k it probably needs a bunch of crap done that didn't get done; so I get to pay for it and go through the hassle of it. I know all things wear out and break, but this sucks.

    Any idea what this thumping could be? Am I right on the a/c compressor maybe? Rod knock....but it quiets down unless the gar is in GEAR and gets worse when the a/c is ON...but the a/c doesn't have to be on for it to make the noise. Anyone else had this problem? It always has to do with load on the engine. I tried to take a video but it didn't pick up the knocking sound well. Now I'm scared I have an $11k paperweight that I owe $ on.
     
  3. Apr 2, 2010 at 6:51 PM
    #3
    redneckkustoms

    redneckkustoms Active Member

    Joined:
    Mar 6, 2010
    Member:
    #32664
    Messages:
    30
    Gender:
    Male
    First Name:
    Chris
    Ky
    Vehicle:
    03 TRD
    Rough Country lift, XD Spy Wheels, 285/70-17 Dunlop Maxx Traction, pioneer double din
    I have the same noise coming from my truck. I actually took it to a transmission shop thinking my torque converter was making the noise since the noise was louder while holding the brake in gear. There was nothing wrong with anything in my transmission so I took all the accessory belts off and checked for slack in the pulleys. Still nothing, so I gave up. Then one day I had been sitting in my truck with no climate control turned on and reach up and turned to defrost, and instantly the noise began knocking again. I haven't replaced my A/C compressor yet, but I'm 99% sure its the culprit of my noise. You may wanna check your compressor a little closer. I have read that the bearings are notorious for going out on them.
     
  4. Apr 2, 2010 at 8:12 PM
    #4
    JRA2000TL

    JRA2000TL [OP] Member

    Joined:
    Mar 24, 2010
    Member:
    #33873
    Messages:
    16
    Gender:
    Male
    Mobile, AL
    Vehicle:
    04 PreRunner SR5 TRD Xtra Cab V6
    I thought was mine was the compressor initially until I'm sitting at a traffic light at idle, in gear, with the climate control OFF...and it still makes the noise. This is frustrating. I've only had the truck 1 week.
     
  5. May 10, 2010 at 7:49 AM
    #5
    bp red

    bp red Well-Known Member

    Joined:
    Sep 10, 2009
    Member:
    #22544
    Messages:
    145
    Gender:
    Male
    First Name:
    Brian
    Chatsworth Ga
    Vehicle:
    09 4x4 dcsb
    My truck is doing this to I have had the trans pulled and the timing belt and tensioner and water pump changed. After the timing belt was chaged it got quiet but with in 3000 miles has got louder again. My last tacoma had a knocking sound but ended up be the ac but this is not what is going on with this one. when i take the ac belt off the noise gets louder. It is driving me crazy!!!!!!
     
  6. Jun 14, 2012 at 8:06 PM
    #6
    Tacoma2525

    Tacoma2525 Member

    Joined:
    Jun 6, 2012
    Member:
    #80195
    Messages:
    11
    Gender:
    Male
    Vehicle:
    03 tacoma prerunner
    has anyone solved this problem yet? Mine is doing the same thing. It has 112,000 miles on it
     
  7. Jun 14, 2012 at 8:18 PM
    #7
    bp red

    bp red Well-Known Member

    Joined:
    Sep 10, 2009
    Member:
    #22544
    Messages:
    145
    Gender:
    Male
    First Name:
    Brian
    Chatsworth Ga
    Vehicle:
    09 4x4 dcsb
    Mine ended up being the main bearings. Tech said it was from over tightening the belts which pulls the crank over and wears the main bearings. End up costing me 1500 to get it fixed. Plus all the money I spent on stuff that didn't fix it Thanks to the dealer.
     
  8. Jun 15, 2012 at 5:50 AM
    #8
    Madjik_Man

    Madjik_Man The Rembrandt of Rattle Can

    Joined:
    Dec 2, 2009
    Member:
    #26893
    Messages:
    13,066
    Gender:
    Male
    Boulder, CO
    Vehicle:
    1998 Ext Cab 4x4 TRD 5MT sunfire red pearl
    About 25 pounds of spray paint and vinyl dye
    Can one of you post an audio clip or YouTube of the noise?
     
  9. Jun 15, 2012 at 7:14 AM
    #9
    MowTaco

    MowTaco Well-Known Member

    Joined:
    Sep 9, 2009
    Member:
    #22530
    Messages:
    3,820
    Gender:
    Male
    First Name:
    Matt
    South Dakota
    Vehicle:
    03 GMC Sierra
    The 4 banger guys have been scratching our heads over something like this for quite awhile... It's mostly second gens that do it but mine does it as well. With the A/C running the truck sounds like a diesel. Let me know how this compares to your noises:

    A/C off:

    [​IMG]

    A/C on:

    [​IMG]

    There's been all sorts of ideas on it and I think a few have had new transmissions and clutches put in under warranty and nobody has solved it to my knowledge as of yet. It doesn't seem to be hurting anything so I'm fine with just living with it.
     
  10. Jun 15, 2012 at 7:40 AM
    #10
    tan4x4

    tan4x4 Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67982
    Messages:
    3,151
    Gender:
    Male
    First Name:
    Rick
    Folsom, CA
    Vehicle:
    99 Tacoma EC 4x4 2.7L Auto
    Bilsteins, OME 881's, 3-leaf AAL, Detroit TruTrac, 31" tires, Michelin LTX AT2, Tranny skidplate, TC skidplate, CBI rear bumper, TG sliders, UltraGauge, PowerTank, Reverse Camera, CB
    In your first post you say 'no noise under the hood'. In your second post you say 'loudest noise came from the a/c compressor'. Kinda confusing.

    You need to do some testing to narrow it down.
    Have you tried removing the A/C belt altogether, and see what happens?

    Could it be the A/C idler pulley? Slight noise while slack, but noisy while under increase load with the A/C on.
     
  11. Jun 18, 2012 at 5:35 PM
    #11
    my6

    my6 Well-Known Member

    Joined:
    Oct 22, 2009
    Member:
    #24712
    Messages:
    56
    Gender:
    Male
    houston,texas
    Vehicle:
    04 prerunner 2wd non trd
    I replaced my compressor last month. It had a similar sound from the way you describe it. It turned out to be that the compressor clutch went bad.
     
  12. Aug 29, 2013 at 6:57 PM
    #12
    mc3404

    mc3404 Well-Known Member

    Joined:
    Aug 28, 2013
    Member:
    #111363
    Messages:
    54
    Gender:
    Male
    Concord ,NC
    Vehicle:
    03 v6 tacoma
    I replaced my compressor and that did not fix mine. I could have swore it was coming from the compressor. Any new suggestions from anyone?
     
  13. Sep 5, 2013 at 5:08 AM
    #13
    woefman

    woefman Member

    Joined:
    Sep 5, 2013
    Member:
    #111871
    Messages:
    9
    Gender:
    Male
    Vehicle:
    95 tacoma 4x4
    none,would love to learn some
    my field coil burnt up a little at a time on my a/c compressor and it melted it to the point it would stick outside the pulley on back side of pulley. causing the noise with or without a/c on . also early tacoma's had a TSB for new a/c lines , for harmonic-ing noises
     
  14. Sep 5, 2013 at 1:58 PM
    #14
    mc3404

    mc3404 Well-Known Member

    Joined:
    Aug 28, 2013
    Member:
    #111363
    Messages:
    54
    Gender:
    Male
    Concord ,NC
    Vehicle:
    03 v6 tacoma
    Where would I find that TSB. Mine is a 2003.
     
  15. Sep 6, 2013 at 3:18 AM
    #15
    woefman

    woefman Member

    Joined:
    Sep 5, 2013
    Member:
    #111871
    Messages:
    9
    Gender:
    Male
    Vehicle:
    95 tacoma 4x4
    none,would love to learn some
    i could print it to a pdf file and email to you if you like
     
  16. Sep 6, 2013 at 12:29 PM
    #16
    mc3404

    mc3404 Well-Known Member

    Joined:
    Aug 28, 2013
    Member:
    #111363
    Messages:
    54
    Gender:
    Male
    Concord ,NC
    Vehicle:
    03 v6 tacoma
    Sure mcauble22@gmail
     
  17. Sep 6, 2013 at 3:27 PM
    #17
    woefman

    woefman Member

    Joined:
    Sep 5, 2013
    Member:
    #111871
    Messages:
    9
    Gender:
    Male
    Vehicle:
    95 tacoma 4x4
    none,would love to learn some
    Hey I just re looked up tsb it only applies to 95-97 i'll post most of it here .... 1. a/c suction hose improvement 95-97 bulletin #ac006-97 The Suction hose length has been increased to reduce vibrations transmitted from compressor 2. a/c liquid tube improvement 95-97 bulletin #ac007-97 The Shape and length of liquid tube # 1 has been changed to reduce vibrations transmitted by compressor. Additional condenser brackets with horizontal braces have replaced the previous supply parts to reduce condenser movement. basically paraphrasing parts of the TSB for you , (to save text typing) in a nutshell it doe snot appear to be for your year truck. Sorry , I was trying to help is all. Man this board is tough to make a post look good When i WROTE IT it was laid out nicely when post it it all blends together like one giant cobbled mess ...makes it not fun to read
     
    Last edited: Sep 6, 2013
  18. Sep 6, 2013 at 4:25 PM
    #18
    mc3404

    mc3404 Well-Known Member

    Joined:
    Aug 28, 2013
    Member:
    #111363
    Messages:
    54
    Gender:
    Male
    Concord ,NC
    Vehicle:
    03 v6 tacoma
    Brother its all good. I appreciate the effort. Im just trying to isolate and eliminate this thumpin noise. It only does it when it is up to operating temperature
     
  19. Sep 8, 2013 at 6:22 AM
    #19
    mc3404

    mc3404 Well-Known Member

    Joined:
    Aug 28, 2013
    Member:
    #111363
    Messages:
    54
    Gender:
    Male
    Concord ,NC
    Vehicle:
    03 v6 tacoma
    Does anyone else's compressor clutch wobble when it is engaged? Is this normal?
     
  20. Sep 11, 2013 at 6:11 AM
    #20
    mc3404

    mc3404 Well-Known Member

    Joined:
    Aug 28, 2013
    Member:
    #111363
    Messages:
    54
    Gender:
    Male
    Concord ,NC
    Vehicle:
    03 v6 tacoma
To Top