1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Who hasn't had ANY problems with their 2nd gen at all?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by especk, Jun 23, 2011.

  1. Jun 23, 2011 at 9:02 PM
    #1
    especk

    especk [OP] Nothin' Special

    Joined:
    Aug 21, 2010
    Member:
    #42041
    Messages:
    2,449
    Gender:
    Male
    First Name:
    Erik
    Redding, CA
    Vehicle:
    2010 Tacoma Reg Cab 4x4
    3" OME lift with 885 coils on nitrocharger 90000 shocks with 5mm trim packer on driver's side, TC UCAs, Rear OME Dakar leafs with nitrocharger shocks, All-pro U-bolt flip kit and 3* Toytec shims, extended rear brakelines, 16" Raceline Rockcrusher 887 wheels with 3.6" backspacking, BFG KM2 305/70/16 tires, Doug Thorley header, Doug Thorley catback exhaust, Volant CAI with ram air, Weathertech floor mats, Kicker 12" sub, Kenwood 500W RMS amp, Relentless Fab front and rear bumpers, 4.88 gears, custom flatbed with swing out tire carrier
    I've seen numerous threads about 2nd gens having problems.

    So who hasn't had any problems at all with their 2nd gen?

    I haven't had any at all - the truck runs perfectly!

    I thought I'd start this thread to even out the threads regarding numerous problems with 2nd gens.


    edit: I just realized I should have made this a poll. Can a mod make some poll for this? It might be easier to see overall results.
     
  2. Jun 23, 2011 at 9:03 PM
    #2
    VooDoo

    VooDoo More Cowbell!

    Joined:
    Dec 5, 2009
    Member:
    #27044
    Messages:
    2,331
    Gender:
    Male
    First Name:
    Carter Ivey
    Baton Rouge, LA/ Starkville, MS
    Vehicle:
    '06 DC LB PreRunner
    66xxx miles and no problems
     
  3. Jun 23, 2011 at 9:04 PM
    #3
    muddin

    muddin Well-Known Member

    Joined:
    Jun 22, 2010
    Member:
    #39309
    Messages:
    1,276
    Gender:
    Male
    PA
    Vehicle:
    2010 Tacoma DC TRD OR
    Bilstein 5100's on all four with some OME 885x's
    im at 21,000 on my 2010 dbl cab trd or and the only thing its been in the shop for was to get the rear tsb done...other than oil changes. quite impressed so far...its my first toyota
     
  4. Jun 23, 2011 at 9:05 PM
    #4
    BlueTaco07

    BlueTaco07 Super Mod!

    Joined:
    Jan 2, 2011
    Member:
    #48598
    Messages:
    2,417
    Gender:
    Male
    First Name:
    Cody
    Panama city, Florida
    Vehicle:
    Looking
    65xxx and nothing excepted a replaced battery.
     
  5. Jun 23, 2011 at 9:07 PM
    #5
    EricT

    EricT Well-Known Member

    Joined:
    Jun 1, 2009
    Member:
    #17887
    Messages:
    516
    Gender:
    Male
    Arizona
    Vehicle:
    '09 4x4 shortbed TRD Sport
    18k miles plus, just ran it hard from az to cali and back - runs like a champ.
     
  6. Jun 23, 2011 at 9:07 PM
    #6
    907taco

    907taco Alaskan Assassin

    Joined:
    Mar 27, 2010
    Member:
    #34091
    Messages:
    1,358
    Gender:
    Male
    First Name:
    Bobby
    Alaska
    Vehicle:
    2010 BlackSandPearl 4x4
    ultimate lift kit ( toytec ) ome dakar leaf pack , w/ extended length billies, LR uca's, Pro comp 7089s, KM2's 285 70 17, neoprene seat covers, weather techs, CBI sliders w/kickout, URD ss, cab mount chop, VHT night shade tint>tails,3rd B-light. Debadged. Grillecraft grille, rear diff breather mod. CBI Moab front bumper, warn M8000 winch, HID kragens 7", Hella's micro fogs. retrofit headlights HIDS, LED solutions maps/license! 886 back up light mod,
    bought in march of 2010> 32,000+ trouble free miles
     
  7. Jun 23, 2011 at 9:07 PM
    #7
    jgwheeler17

    jgwheeler17 I'm a zit. Get it?

    Joined:
    Dec 3, 2010
    Member:
    #47112
    Messages:
    10,033
    Gender:
    Male
    NC
    Vehicle:
    07 Double Cab TRD Off-Road 4x4
    tint, dents, scratches, two blown speakers and trying to pay her off...
    put somewhere less than 10k miles on it in the 6 months i've owned it. bought it used with 90k on it. not one problem. i love it.
     
  8. Jun 23, 2011 at 9:09 PM
    #8
    Unknown

    Unknown He who angers you conquers you

    Joined:
    Apr 18, 2010
    Member:
    #35554
    Messages:
    8,158
    Gender:
    Male
    First Name:
    Brian
    Los Angeles
    Vehicle:
    Unknown
    Unknown
    201k on my 1st gen, no problems.
     
  9. Jun 23, 2011 at 9:09 PM
    #9
    especk

    especk [OP] Nothin' Special

    Joined:
    Aug 21, 2010
    Member:
    #42041
    Messages:
    2,449
    Gender:
    Male
    First Name:
    Erik
    Redding, CA
    Vehicle:
    2010 Tacoma Reg Cab 4x4
    3" OME lift with 885 coils on nitrocharger 90000 shocks with 5mm trim packer on driver's side, TC UCAs, Rear OME Dakar leafs with nitrocharger shocks, All-pro U-bolt flip kit and 3* Toytec shims, extended rear brakelines, 16" Raceline Rockcrusher 887 wheels with 3.6" backspacking, BFG KM2 305/70/16 tires, Doug Thorley header, Doug Thorley catback exhaust, Volant CAI with ram air, Weathertech floor mats, Kicker 12" sub, Kenwood 500W RMS amp, Relentless Fab front and rear bumpers, 4.88 gears, custom flatbed with swing out tire carrier
    no problems at all. no rattling, weird noises, or anything else that shouldn't be there or have gone wrong. it's kind of subjective i guess but be reasonable.

    Being stranded would be on the extreme side of 'yes something went wrong'
     
  10. Jun 23, 2011 at 9:10 PM
    #10
    tbturner47

    tbturner47 Well-Known Member

    Joined:
    Apr 17, 2010
    Member:
    #35484
    Messages:
    1,130
    Gender:
    Male
    First Name:
    Travis
    Lenoir, NC
    Vehicle:
    '07 Indigo Ink Off Road
    Supercharger
    45,xxx and nothing but the rear tsb just for the extra lift
     
  11. Jun 23, 2011 at 9:13 PM
    #11
    sechsgang

    sechsgang Well-Known Member

    Joined:
    Oct 18, 2007
    Member:
    #3112
    Messages:
    361
    Gender:
    Male
    Vehicle:
    06 DC TRD OR 4WD 6spd
    58K miles, no problems after the warranty expired.
    Before that? I think it was a total of 26 days in the shop (outside of oil changes, lol), for a total of around $10,000 in warranty repairs. Since then: all is good.
    Not the most reliable vehicle I have owned (actually the worst) if you include warranty repairs. Outside of warranty --- no problems.
     
  12. Jun 23, 2011 at 9:13 PM
    #12
    toyotatacomaTRD

    toyotatacomaTRD Senior Member

    Joined:
    Sep 16, 2010
    Member:
    #43379
    Messages:
    1,204
    Gender:
    Male
    First Name:
    Rob
    Pacific Northwest
    Vehicle:
    2005 4x4 DC TRD Off Road
    11 Color Matched Grille, Pro comp 7089s, 265/70/17 Wrangler Duratracs, Black Running Boards, Tinted Windows, Bed mat, Weathertech Floorliners
    My 05 is still problem free. Nothing other than routine maintenance.
     
  13. Jun 23, 2011 at 9:16 PM
    #13
    TnRedNeck721

    TnRedNeck721 GO VOLS!

    Joined:
    Mar 10, 2011
    Member:
    #52731
    Messages:
    19,142
    Gender:
    Male
    First Name:
    Zach
    TN
    Vehicle:
    07 TRD off road 4WD
    No mud flaps, plasti dipped emblems, and rear bumper, Weather tech digital fit, Bed mat from tractor supply. Pioneer 4400BH head unit. B.A.M.F bed rail tie downs. AVS vent visors.
    i have not had any. truck is '07 with 265** as of today! we did get it used. but i can't find a thing wrong. only had it a little over a month.
     
  14. Jun 23, 2011 at 9:16 PM
    #14
    OffroadToy

    OffroadToy This ain't Dodge City, and you ain't Bill Hickok

    Joined:
    Sep 12, 2009
    Member:
    #22680
    Messages:
    5,263
    Gender:
    Male
    Vehicle:
    07 TRD OFFROAD 4x4 VSC/TRAC/DAC/HAC
    snugtop, piaa, weathertech, westin, oem bed mat, trd seat covers, avs inchannel vent visors, 2" suspension lift, front diff drop, rear differential breather extension, oil filter drain hose, a/c drain hose extention & reroute, front window tint, cat theft protection plate, tailgate clamp mod, xpel headlight/foglight protecters, oem block heater, bfg 265/75R/16 a/t k/o's, cabin air rodent protection screen, rcbs illuminated 4X4 switch mod
    My 07 has 16,750 miles now. So far the only issue has been a tail light bulb burned out.
     
  15. Jun 23, 2011 at 9:20 PM
    #15
    colinb17

    colinb17 If at first you don't succeed, don't try skydiving

    Joined:
    Jan 6, 2008
    Member:
    #4127
    Messages:
    18,609
    Gender:
    Male
    First Name:
    Colin
    Lusby, MD
    Vehicle:
    '07 TRD Sport 4x4
    Build thread in sig...
    all problems with mine have been a direct result of me and an "incident" while wheeling. so i'd say i've had zero problems in the way the question was asked.
     
  16. Jun 23, 2011 at 9:25 PM
    #16
    especk

    especk [OP] Nothin' Special

    Joined:
    Aug 21, 2010
    Member:
    #42041
    Messages:
    2,449
    Gender:
    Male
    First Name:
    Erik
    Redding, CA
    Vehicle:
    2010 Tacoma Reg Cab 4x4
    3" OME lift with 885 coils on nitrocharger 90000 shocks with 5mm trim packer on driver's side, TC UCAs, Rear OME Dakar leafs with nitrocharger shocks, All-pro U-bolt flip kit and 3* Toytec shims, extended rear brakelines, 16" Raceline Rockcrusher 887 wheels with 3.6" backspacking, BFG KM2 305/70/16 tires, Doug Thorley header, Doug Thorley catback exhaust, Volant CAI with ram air, Weathertech floor mats, Kicker 12" sub, Kenwood 500W RMS amp, Relentless Fab front and rear bumpers, 4.88 gears, custom flatbed with swing out tire carrier
    thanks for using ur brain to answer the question, seriously :)
     
  17. Jun 23, 2011 at 9:26 PM
    #17
    mcleod90

    mcleod90 150,000 miles and counting

    Joined:
    Oct 30, 2010
    Member:
    #45456
    Messages:
    485
    Gender:
    Male
    First Name:
    sean
    modesto ca
    Vehicle:
    05 double cab
    153xxx on my 05. Bought it with 150xxx on it runs like my 2010 I had that was brand new. So no problems yet (knock on wood)
     
  18. Jun 23, 2011 at 9:39 PM
    #18
    sechsgang

    sechsgang Well-Known Member

    Joined:
    Oct 18, 2007
    Member:
    #3112
    Messages:
    361
    Gender:
    Male
    Vehicle:
    06 DC TRD OR 4WD 6spd
    You switched from a 2010 to an '05?
     
  19. Jun 23, 2011 at 9:43 PM
    #19
    CorrosiveTendency

    CorrosiveTendency When up to your nose in shit, keep your mouth shut

    Joined:
    Sep 29, 2010
    Member:
    #43987
    Messages:
    1,856
    Gender:
    Male
    First Name:
    Nathan S.
    Schuylkill Co, Pa
    Vehicle:
    05' DblCab SB Speedway Blue
    OME 885's, Locker Mod. Bilstein 5100's on 4 corners
    I would rather not jinx myself, so let's just say....my '05 is right in line with my MUCH MISSED '99
     
  20. Jun 23, 2011 at 9:53 PM
    #20
    mcleod90

    mcleod90 150,000 miles and counting

    Joined:
    Oct 30, 2010
    Member:
    #45456
    Messages:
    485
    Gender:
    Male
    First Name:
    sean
    modesto ca
    Vehicle:
    05 double cab
    Ya I switched from a regular cab, I needed the double cab and having the v6 is nice. And it worked out better financially for me. And im pretty sure with regular maintance it will go 300,000 miles easily, but I'll probably have a tundra by then ;)
     
To Top