1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Why AC Delco? why!? WHY?!

Discussion in 'Audio & Video' started by Ends, Dec 22, 2009.

  1. Dec 22, 2009 at 8:56 PM
    #1
    Ends

    Ends [OP] Well-Known Member

    Joined:
    Nov 11, 2009
    Member:
    #25769
    Messages:
    50
    Gender:
    Male
    Must you suck so god damn much.

    This will be the 3rd time i will go into my dealer ship and ask for a new head unit for my 09 taco. Each unit has had the same problems, tracks, stations, volume skipping, and random power downs.

    My dealership plays stupid, and insists im the only issue they know about. I don't believe them for a second.

    But what really gets me is when i had to wait 2 months for my second unit. Apparently they lost the order at Delco. When i heard that my dealership was waiting for a Delco part, it hit me. What the hell is toyota doing? Don't they know that GM sucks, and if i wanted shit parts i would have got a GM and saved money? People buy Toyota's because we assume they use better parts, not the same.


    Granted its not a big deal, and just a radio. But still, this is my 3rd one and needed to rant. Its not hard to put a good unit there for the start. The little things do go a long way. They just dropped the ball with this new style of shitty headunits, and 2" rear speakers. :mad::mad::mad:
     
  2. Dec 22, 2009 at 9:33 PM
    #2
    mountainwolfpup

    mountainwolfpup Ford Guy (Formerly known as a Toyota Guy)

    Joined:
    Jan 1, 2009
    Member:
    #12116
    Messages:
    980
    Gender:
    Male
    Vancouver, WA
    Vehicle:
    2015 Ford F150 Lariat FX4 3.5l Eco
    First month of ownership... This month I'm removing front air dam, and also Rhino lining the bed.
    Yeah I've been reading about a lot of problems with the factory radio from all years of the 2nd gen 05 - 09. Seems like a lot especially with the JBL deck setup? Too bad.

    My 07 has the stock 6-disk unit and has never had any issues with the quality, but the sound quality is underwhelming.. I blame the 6x9 speakers for that though.

    Anyway my advice is to buy a new deck and some 6.5" round speakers and an amp. Won't set you back more then a few hundred and it'll sound awesome.
     
  3. Dec 23, 2009 at 7:50 AM
    #3
    soilsample

    soilsample Well-Known Member

    Joined:
    Dec 3, 2009
    Member:
    #26958
    Messages:
    143
    Gender:
    Male
    First Name:
    Donald
    Southwest Louisiana
    Vehicle:
    '09 4x4 Double Cab
    My new '09 that I bought a few weeks ago is having random power downs of the head unit.
    I didn't know that it was a common issue........ sometimes It comes back on when I hit the button, other times it takes several attempts.
    I'm gonna bring it in to have it changed soon.
     
  4. Dec 23, 2009 at 7:59 AM
    #4
    Jester243

    Jester243 mod status????

    Joined:
    Jun 25, 2008
    Member:
    #7552
    Messages:
    10,004
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 Trail Premium 4Runner w/ KDSS

    I though the radio problems only affected the 2009 and 2010's?
     
  5. Dec 23, 2009 at 8:02 AM
    #5
    Danosabre

    Danosabre Well-Known Member

    Joined:
    Oct 16, 2009
    Member:
    #24388
    Messages:
    1,042
    Gender:
    Male
    First Name:
    Dan
    Gardner,Ma
    Vehicle:
    09 TRD Off Road
    Extang Trifold bed cover,DDM 55W 6000k HID, maglight, Vent visors
    Hadn't heard of this one. I haven't had any problems with mine...... yet
     
  6. Dec 23, 2009 at 9:47 PM
    #6
    Ends

    Ends [OP] Well-Known Member

    Joined:
    Nov 11, 2009
    Member:
    #25769
    Messages:
    50
    Gender:
    Male
    100%. I was planing to do this anyway, get a nice HU in there, but its still the prince-able that the truck is less then a year old, and with the coin i paid, i thought i was getting a good "6 speaker" system. Little did i know (or fail to check, i guess) that it just sucked. headliner speakers, lol. I think the mounts are still there in the half doors, under the panels? Ill have to check one of these days.

    It just pains me to see cheaper cars, with better sounding stock systems. :(
     
To Top