1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Worst Year for 2nd gen tacos ?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by newtaco2008, Nov 8, 2010.

  1. Nov 8, 2010 at 5:01 PM
    #1
    newtaco2008

    newtaco2008 [OP] Well-Known Member

    Joined:
    Mar 29, 2010
    Member:
    #34196
    Messages:
    90
    Gender:
    Male
    Fort Mill, SC
    Vehicle:
    08 prerunner indigo ink pearl
    What is the most problem plagued year for 2nd gen, just curious, my 2008 has had some problems but I still like it and will prolly drive it until it drops...
     
  2. Nov 8, 2010 at 5:59 PM
    #2
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,558
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    I say 2005.
     
  3. Nov 8, 2010 at 6:03 PM
    #3
    MY50cal

    MY50cal I think I'm getting the Fear.

    Joined:
    Apr 5, 2009
    Member:
    #15613
    Messages:
    2,744
    Gender:
    Male
    First Name:
    Mojo
    Parkesburg, PA
    Vehicle:
    05 SWB TRD 4x4
    Yes.
    :argue:

    I have had zero issues with mine... just hit 85K... :cool:
     
  4. Nov 8, 2010 at 6:05 PM
    #4
    trd09

    trd09 Well-Known Member

    Joined:
    Jul 20, 2009
    Member:
    #19899
    Messages:
    279
    Gender:
    Male
    First Name:
    Chuck
    MA
    Vehicle:
    09 TRD Sport AC 4x4
    4-leaf TSB, 5100s @ 1.75, Flowmaster 40, Undercover Tonneau, K&N drop-in, Nittos, NGK Iridiums, OME N182s
    my 09 has been great
     
  5. Nov 8, 2010 at 6:08 PM
    #5
    NWtacoma

    NWtacoma Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18142
    Messages:
    1,689
    Gender:
    Male
    Kent,WA
    Vehicle:
    2011 TRD Sport 4x4
    265/70/17 bfg AT
    07 here, only problem i got is that there are crickets in my fan blower.
     
  6. Nov 8, 2010 at 6:15 PM
    #6
    nomad

    nomad Well-Known Member

    Joined:
    Apr 14, 2007
    Member:
    #1313
    Messages:
    263
    Gender:
    Male
    Didn't the '05 come with shorter mud flaps than the '06+?
     
  7. Nov 8, 2010 at 6:15 PM
    #7
    easyeatlanta

    easyeatlanta Artificial Intelligence beats natural stupidity

    Joined:
    Aug 10, 2010
    Member:
    #41518
    Messages:
    1,242
    Gender:
    Male
    First Name:
    Eric
    Memphis
    Vehicle:
    14 DC Trd Off Road
    my 05 has 95k no problems and starts like a champ everytime
     
  8. Nov 8, 2010 at 6:16 PM
    #8
    newtaco2008

    newtaco2008 [OP] Well-Known Member

    Joined:
    Mar 29, 2010
    Member:
    #34196
    Messages:
    90
    Gender:
    Male
    Fort Mill, SC
    Vehicle:
    08 prerunner indigo ink pearl
    I also have a fluttering/ticking fan blower noise, taking it in on Wed. There is a TSB on this problem.
     
  9. Nov 8, 2010 at 6:50 PM
    #9
    NWtacoma

    NWtacoma Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18142
    Messages:
    1,689
    Gender:
    Male
    Kent,WA
    Vehicle:
    2011 TRD Sport 4x4
    265/70/17 bfg AT
    yea but tsb is worthless and doesnt fix the problem. :rolleyes:
     
  10. Nov 8, 2010 at 6:52 PM
    #10
    APTJ

    APTJ Well-Known Member

    Joined:
    Dec 5, 2009
    Member:
    #27045
    Messages:
    275
    Gender:
    Male
    First Name:
    Eric
    Texas
    Vehicle:
    2005 Dcab SR5 4x4
    grill, lights, bull bar, rims, tires,
    thats what you think..hehe
     
  11. Nov 8, 2010 at 6:58 PM
    #11
    myname150

    myname150 Well-Known Member

    Joined:
    Jul 5, 2010
    Member:
    #39827
    Messages:
    1,351
    Gender:
    Male
    08 at 45,000 Miles With only a few complaints but they dont really bother me, ive gotten used to them or found ways around them.

    - Mushy Brake Pedal
    - I'm guessing it is normal, but when i start the truck it should fire up instantly like our other cars do.
    - Sometimes (it somehow has gotten better on its own) the A/C Fan Unit or whatever is behind the glove box needs to stop squeaking
    - Squeaky Leaf Springs
    - Atleast some sort of confirmation tone when you unlock/lock the doors + the door ajar tone. Standard.
    - I REALLY hate how the 09's started rolling out a few months after we bought this 2008 model. The 09's had standard side airbags, AUX input and an ALSD...
     
  12. Nov 8, 2010 at 7:03 PM
    #12
    The1youluv2hate

    The1youluv2hate Well-Known Member

    Joined:
    Sep 14, 2010
    Member:
    #43233
    Messages:
    2,692
    Gender:
    Male
    First Name:
    Peps
    SP... CaL
    Vehicle:
    11 TRD sPort
    5100's@1.75 Horns (Andres) Satoshi TRD cat back BHLM
  13. Nov 8, 2010 at 7:14 PM
    #13
    steve o 77

    steve o 77 braaap

    Joined:
    Nov 29, 2009
    Member:
    #26726
    Messages:
    19,952
    Gender:
    Male
    First Name:
    Steven
    In a corn field, OH
    Vehicle:
    2001 4x4 5Spd Xtra Cab V6
    205k+ miles, 265/75/16 BFG A/T's, OME 881's, Wheelers 5 leaf pack, 5100's, Home Made Sliders
    05 only because of the motor mount issues. Its really only an issue if you jump the truck though.

    Now just to stir the pot, 05+ are the worst.:D
     
  14. Nov 8, 2010 at 7:17 PM
    #14
    whitebread

    whitebread Well-Known Member

    Joined:
    Jan 11, 2009
    Member:
    #12489
    Messages:
    843
    Gender:
    Male
    First Name:
    Chris
    Raleigh, NC
    Vehicle:
    2011 4x4 DCSB TRD Off-Road
    Leer 100XL and a bunch of off-roading scars.
    That was fixed for 2011. They are rock hard now. Almost too hard... :p
     
  15. Nov 8, 2010 at 10:20 PM
    #15
    mr2crazed

    mr2crazed Well-Known Member

    Joined:
    May 21, 2009
    Member:
    #17512
    Messages:
    191
    Gender:
    Male
    Morro Bay, CA.
    Vehicle:
    06 DC PreRunner SR5
    You sure its not because you have a brand new truck with new brakes/fluid?
     
  16. Nov 8, 2010 at 10:30 PM
    #16
    DWreck

    DWreck Famous Fabrication Vendor

    Joined:
    May 18, 2010
    Member:
    #37368
    Messages:
    5,128
    Gender:
    Male
    First Name:
    Derek
    Las Vegas, NV
    Vehicle:
    2010 TRD Off Road 4x4
    Debadged, k&n cai, tc uca, billy 5100, led hood lights, redline hood struts, tailgate ez-down, ddm hid heads, Piaa 510 hid fogs, procomp 7089, dunlop fierce mt, cb and ham radios, hideaway strobes, ff front bumper, ff sliders, bed rack,
    05 only cause its first year. My 07 also had the crickets in the blower. Change your cabin filter.
     
  17. Nov 8, 2010 at 10:30 PM
    #17
    island808

    island808 Me l've got brains.

    Joined:
    Oct 9, 2010
    Member:
    #44414
    Messages:
    1,896
    Gender:
    Male
    First Name:
    Jedediah
    hawaii
    Vehicle:
    '10 6speed 4x4 access cab
    If you want to turn off the abs and junk.. 2009+ are the ones to avoid.
    If you don't believe in electronic brake lockers and LSDs.. 2009+ are to be avoided.
    They're pretty much all the same. The first few years had weaker tailgates. But could be retrofitted.
    THe automatics have been buggy since day one by the looks of the forum. The cup holders (at least in the 6 speed) changed a little as did the color of the dash and the led tail lights are a 2009 thing?
    2011 has the neat new grill.. but hardly worth worrying about. Its about 200 bucks at your dealer.
     
  18. Nov 8, 2010 at 10:37 PM
    #18
    Kyouto42

    Kyouto42 Iron Beard

    Joined:
    Aug 18, 2008
    Member:
    #8614
    Messages:
    9,161
    Gender:
    Male
    First Name:
    Jake
    Ahwatukee, AZ
    Vehicle:
    BSP '10 4x4 TRD Off-Road DC
    See build thread in signature
    The dash didn't change at all 05-11... It's exactly the same color... >.>
    ABS was on 05+ as well.

    The primary issues were the motor mount issue (05 potentially early 06), weak tailgates (fixed in 08+ or via TSB), 6spd throwout bearing issue (not fixed period), noisy blower motor (no true fix, best solution is to grease it yourself), windshield noise on earlier models (TSB fix), and the JBL radio issues 09 and some 10's. Those are pretty much the primary issues that affected most vehicles. There's also little stuff that randomly pop up as with any manufacture/model.
     
  19. Nov 8, 2010 at 10:41 PM
    #19
    genxer36

    genxer36 Lord of Tomfoolery

    Joined:
    Nov 13, 2007
    Member:
    #3442
    Messages:
    10,603
    Gender:
    Male
    First Name:
    Sean
    Bethlehem,GA
    Vehicle:
    2013 Toyota Camry SE - 2011 Tacoma traded
    Tow package, XM Satellite radio, K & N Air filter, & Channel Vent Visors

    WRONG!!! Thanks for playing.


    My 2005 has 165,500 miles on it. Only replacements other than normal maintenance: 5 year old battery, & a universal joint.
     
  20. Nov 8, 2010 at 10:47 PM
    #20
    genxer36

    genxer36 Lord of Tomfoolery

    Joined:
    Nov 13, 2007
    Member:
    #3442
    Messages:
    10,603
    Gender:
    Male
    First Name:
    Sean
    Bethlehem,GA
    Vehicle:
    2013 Toyota Camry SE - 2011 Tacoma traded
    Tow package, XM Satellite radio, K & N Air filter, & Channel Vent Visors
    Apparently you forgot Toyota has been making the 2nd gen Tacoma for years before 2005. It was called the Tundra & the T100. It was rebadged as the Tacoma, so Toyota could move the Tundra to the Full size class & The Tacoma to the mid sized class.
     
To Top