1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

4.5k on odo and MAIN REQD WTF !!!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by rendertrust, May 21, 2010.

  1. May 21, 2010 at 7:30 PM
    #1
    rendertrust

    rendertrust [OP] Member

    Joined:
    Jan 26, 2010
    Member:
    #30070
    Messages:
    22
    Gender:
    Male
    I have a 2010 2.7 Prerunner got her 2 months ago. I put 4.5k on her and she blinks maintenance required during the first 20 seconds of startup then shuts off. The truck doesn't vibrate roughly like a misfire and doesn't make any other symptoms.

    I wont be able to take her in till tuesday but any of you guys hear of something like this ? :confused: I got a toyota because its suppose to be reliable !


    Maybe shes asking for an oil change ?
     
  2. May 21, 2010 at 7:32 PM
    #2
    08pretaco

    08pretaco Almost there

    Joined:
    Sep 26, 2008
    Member:
    #9502
    Messages:
    9,059
    Gender:
    Male
    First Name:
    Oliver
    az
    Vehicle:
    2014 Tundra 4x4 CM 5.7L SR5
    AFE pro dry s, Husky X-act Contour
    its time for an oil change relax lol

    it blinks as a reminder and then stays on when its for sure time to get that shit done!

    i hope your gonna change the oil yourself lol theres a diy and then theres a post on how to reset the maint required light :) happy searching
     
  3. May 21, 2010 at 7:59 PM
    #3
    tacobox

    tacobox Evasive Maneuvers PMKMS

    Joined:
    May 9, 2010
    Member:
    #36834
    Messages:
    597
    Gender:
    Male
    First, set the ODO in the standard position. Then, with the truck off, hold the odometer button down. Turn to on/run position, not start (still holding odo button down). Odometer will flash a countdown and then display all zeros which indicates the Maint Req light is reset.
    It comes on every 4500-5000.
     
  4. May 21, 2010 at 8:12 PM
    #4
    Redfox1

    Redfox1 'Stralia! Riding Roo's and wrangling koalas

    Joined:
    Oct 10, 2009
    Member:
    #24099
    Messages:
    1,595
    Gender:
    Male
    First Name:
    Conner
    Santa Paula, CA and SLO
    Vehicle:
    09 Prerunner Sport TRD
    Browning Floor Mats, 275/70/17 BFG All-Terrain T/A's, Procomp 7089 wheels,Rear Spring TSB, Bilstein 5100's, LED roof light, seatbelt chime disabled, CB, UWS Toolbox,
    Also i believe tcbob has a sticky somewhere on this...
     
  5. May 21, 2010 at 8:15 PM
    #5
    lookylookitzadam

    lookylookitzadam Retrofit Club!

    Joined:
    Jul 16, 2009
    Member:
    #19777
    Messages:
    713
    Gender:
    Male
    First Name:
    Adam
    San Diego
    Vehicle:
    07 DC OffRoad
    Check engine light is what you need to worry about, btw
     
  6. May 21, 2010 at 8:28 PM
    #6
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    X2.
     
  7. May 21, 2010 at 8:40 PM
    #7
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Its a public forum, but that doesnt mean people have to be dicks when answering questions. Options to consider:
    "Have you checked in the owners manual?"
    "There is a 'sticky' on it"
    "Press and hold ODO reset button with engine "Off", then insert and turn key to the "On" position".


    Etc.
     
  8. May 21, 2010 at 8:40 PM
    #8
    bambooshoots

    bambooshoots Be a fountain, not a drain.

    Joined:
    Jun 29, 2008
    Member:
    #7645
    Messages:
    720
    Gender:
    Male
    First Name:
    Kevin
    College Station, TX
    Vehicle:
    2015 Honda Accord Sport
    I did it again. Got tired of paying truck payments and gas and traded in for a 2015 Honda Accord Sport since I enjoyed my 2013 Sport so much.
    haha great thread title...
    but yeah, oil change, and don't forget to reset the oil ODO.
     
  9. May 21, 2010 at 8:41 PM
    #9
    Wolfman

    Wolfman Well-Known Member

    Joined:
    Mar 21, 2010
    Member:
    #33624
    Messages:
    389
    Gender:
    Male
    Paradise, TX
    Vehicle:
    2010 PreRunner SR5

    Yes, the procedure is in the manual. I just did mine a couple of days ago. I'm now running Mobil 1 0w20 full synthetic. The 2.7 also holds 6.1 quarts including filter.
     
  10. May 21, 2010 at 8:44 PM
    #10
    jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Moderator

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    28,096
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    leave the n00b and other member bashing to those other forums. user needed to be informed and now he has
     
  11. May 21, 2010 at 9:08 PM
    #11
    ForeRunner

    ForeRunner Scotch before noon. Moderator

    Joined:
    Sep 9, 2006
    Member:
    #7
    Messages:
    12,098
    Gender:
    Male
    First Name:
    Drunken Sailor
    Somewhere between Maine and Florida
    Vehicle:
    2016 Subaru WRX STI Limited (no wing)
    Extra PSI
  12. May 22, 2010 at 9:09 AM
    #12
    81shark

    81shark Well-Known Member

    Joined:
    Nov 7, 2008
    Member:
    #10567
    Messages:
    1,680
    Gender:
    Male
    Vehicle:
    2006 Base Access CP1
    clearly, the skin is thin. think i will hit the X up in the corner for a while
     
  13. May 22, 2010 at 6:08 PM
    #13
    2.7taco

    2.7taco Well-Known Member

    Joined:
    Dec 9, 2009
    Member:
    #27316
    Messages:
    522
    Gender:
    Male
    Texas
    Vehicle:
    2005 Tan Tacoma Base 5 LUG: Beaten , abused and still running strong.
    Fat Bobs 2.75 lift and level with short AAL, 16x8 Level 8 Guardian Wheels, 245/75R16 Toyo Open Country ATII, custom trans shift kit(home made), Trans temp. and Vac gauge, URD fuel pump upgrade(going back to stock soon).
    Just the oil change light not a thing wrong. You might as well switch over to synthetic while you have the opportunity.
     
To Top