1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Compass / Temp gauge

Discussion in '2nd Gen. Tacomas (2005-2015)' started by MyToyTaco, Sep 26, 2008.

  1. Sep 26, 2008 at 9:21 AM
    #1
    MyToyTaco

    MyToyTaco [OP] ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,320
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
    So about a month ago these gauge lights started flickering on / off, then about a week after that they turned off, but would flicker if i tapped on the plastic housing.. then a week after that completely stopped coming on.

    Sounds like a loose bulb or wire to me..

    I wanted to see if anyone else has had this problem and had any input before i started taking it apart?
     
  2. Sep 26, 2008 at 9:23 AM
    #2
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    I hope you bought an extended warranty...

    It sounds like a loose wire, but those things are known to go out and stay out. I think it is about $700, if you need to replace it.
     
  3. Sep 26, 2008 at 9:25 AM
    #3
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    user beeftaco is a toyota tech and he has had to replace a few of them. If he doesn't chime in here soon, shoot him a PM.
     
  4. Sep 26, 2008 at 9:26 AM
    #4
    MyToyTaco

    MyToyTaco [OP] ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,320
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
    ouch....no warranty :eek:

    eff it, my radar has a compass lol.
     
  5. Sep 26, 2008 at 9:30 AM
    #5
    jolayiv

    jolayiv Carolina Alliance

    Joined:
    Aug 25, 2008
    Member:
    #8757
    Messages:
    1,131
    Gender:
    Male
    First Name:
    Jim
    New Bern NC
    Vehicle:
    07 DC TRD 4x4 Off-Road
    Revenge-Fab Sliders, AVS Vent Guards, Rear TSB, Hose clamp MOD, Locker MOD, Flowmaster 40 Series Delta Flow, Midland Radio, Wilson 1000 antenna, Rear Diff breather MOD, Weathertech liners, Maglite mount, Bed Divider, LEER 100XR, Pop&Lock
    I think you should still take a look at it. If it is just a loose wire then it's a simple fix. Anything electrical can be fixed. Finding the problem is usually the hardest part.
     
  6. Sep 26, 2008 at 9:33 AM
    #6
    MyToyTaco

    MyToyTaco [OP] ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,320
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
    I think I will..

    lsocoee-- i read your comment on another thread about the overhead console and taking it off; take the one screw out and pull straight down, not back. I did this yesterday and it seemed like i was going to have to use a bit of force to pull it down...wanted to double check on this before i started breaking crap...?
     
  7. Sep 26, 2008 at 9:43 AM
    #7
    Dark Knight

    Dark Knight Well-Known Member

    Joined:
    Jul 18, 2008
    Member:
    #8006
    Messages:
    9,592
    Gender:
    Male
    First Name:
    Jeff
    NC/SC
    Vehicle:
    4Runner Trail
    My compass blinked at me one night and then went out. i got pissed, punched it, and it came back on and has obeyed since!
     
  8. Sep 26, 2008 at 9:49 AM
    #8
    MyToyTaco

    MyToyTaco [OP] ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,320
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
    that worked at first, but mine didn't obey :rolleyes:
     
  9. Sep 26, 2008 at 10:59 AM
    #9
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    it takes some effort to pull the console down. Even with knowing the mechanism holding it up, I'm still worried that I'd break it when I tried to pull it down. There are two metal clips on the edge next to the windshield. If you pull straight down, then they should pop out. The edge away from the windshield has some clips that allow it to rotate around that edge and then it comes off.
     
  10. Sep 26, 2008 at 11:03 AM
    #10
    MyToyTaco

    MyToyTaco [OP] ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,320
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
    Ok, so the edge closest to the windshield is the edge you pull straight down? I was trying to pull the opposite end down last night..good thing i stopped! Thanks for the info..
     
  11. Sep 30, 2008 at 1:10 PM
    #11
    MyToyTaco

    MyToyTaco [OP] ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,320
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
    The unit is fried. once i got it apart to look at it, i noticed theres a black burnt spot on the glass lens. Look with a magnifying glass inside and it seems the little tiny metal prongs inside the glass is what fried. or something. Toyota says i gotta buy the whole F~ing overhead console, for $900. Any suggestions?
     
  12. Sep 30, 2008 at 1:28 PM
    #12
    Dark Knight

    Dark Knight Well-Known Member

    Joined:
    Jul 18, 2008
    Member:
    #8006
    Messages:
    9,592
    Gender:
    Male
    First Name:
    Jeff
    NC/SC
    Vehicle:
    4Runner Trail
    F $900 for that thing put in a sunroof and the non compass console.
     
  13. Sep 30, 2008 at 1:33 PM
    #13
    MyToyTaco

    MyToyTaco [OP] ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,320
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
    Yah i'm starting to think of alternatives. I've called quite a bit of wrecking yards and nobody has it.
     
  14. Sep 30, 2008 at 1:57 PM
    #14
    wushaw

    wushaw Well-Known Member

    Joined:
    Jul 20, 2008
    Member:
    #8037
    Messages:
    99
    Texas
    Vehicle:
    08 AC TRD 4x4 6sp
    Rearview mirror compass and put something else there.
     
  15. Nov 9, 2008 at 1:02 PM
    #15
    Kyouto42

    Kyouto42 Iron Beard

    Joined:
    Aug 18, 2008
    Member:
    #8614
    Messages:
    9,243
    Gender:
    Male
    First Name:
    Jake
    Ahwatukee, AZ
    Vehicle:
    BSP '10 4x4 TRD Off-Road DC
    See build thread in signature
    Wow... for 9 bills the damn compass/temp gauge could at least be ACCURATE. :/
     
  16. Nov 9, 2008 at 1:10 PM
    #16
    coppert

    coppert Mall Krawler

    Joined:
    Apr 12, 2007
    Member:
    #1300
    Messages:
    916
    Gender:
    Male
    First Name:
    Travis
    916
To Top