1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

(finally fixed) Crank, crank, Craaaaank, won't start thread...

Discussion in '2nd Gen. Tacomas (2005-2015)' started by FishaRnekEd, Jan 14, 2022.

  1. Jan 15, 2022 at 10:12 AM
    #61
    Dm93

    Dm93 Test Don't Guess

    Joined:
    Mar 3, 2015
    Member:
    #150066
    Messages:
    3,167
    Gender:
    Male
    Texas
    Vehicle:
    2014 DC OR 6spd 4x4
    Predator tube steps, Ranch Hand grill guard, Magnaflow CatBack exhaust, Toyota tool box & bed mat, 2LO Module by @Up2NoGood, Rearview Compass/Temp Mirror.
    FishaRnekEd [OP] and TnShooter like this.
  2. Jan 15, 2022 at 10:51 AM
    #62
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    8,336
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    I having a hard enough time keep up with why anyone would want to drop a 302 in a Ranger. Lol

    yeap, my father is back on that again. :rofl:
     
    Larzzzz, FishaRnekEd [OP] and Dm93 like this.
  3. Jan 15, 2022 at 11:43 AM
    #63
    FishaRnekEd

    FishaRnekEd [OP] Well-Known Member

    Joined:
    Dec 11, 2013
    Member:
    #118381
    Messages:
    707
    Gender:
    Male
    New Orleans, LA
    Vehicle:
    2005 4.0 6spd 4x4 Dbl Cb short bed
    Shoot, i was about to start making a flat bed for my taco, before all this electronic nonsense started... Now I'm set back a month.
     
    TnShooter likes this.
  4. Jan 15, 2022 at 11:45 AM
    #64
    FishaRnekEd

    FishaRnekEd [OP] Well-Known Member

    Joined:
    Dec 11, 2013
    Member:
    #118381
    Messages:
    707
    Gender:
    Male
    New Orleans, LA
    Vehicle:
    2005 4.0 6spd 4x4 Dbl Cb short bed
    Same here, i don't usually remember names. I remember my customers by their motorcycle.
     
  5. Jan 15, 2022 at 4:10 PM
    #65
    Dm93

    Dm93 Test Don't Guess

    Joined:
    Mar 3, 2015
    Member:
    #150066
    Messages:
    3,167
    Gender:
    Male
    Texas
    Vehicle:
    2014 DC OR 6spd 4x4
    Predator tube steps, Ranch Hand grill guard, Magnaflow CatBack exhaust, Toyota tool box & bed mat, 2LO Module by @Up2NoGood, Rearview Compass/Temp Mirror.
    Ok so I did a little experimenting on my truck by wrapping some foil around the head of the key so it couldn't be read (would be the same as having a unchipped or dead key).
    The truck will crank but not fire at all.
    It does not cut power to the EFI fuse.
    The security light continues to blink in all key positions at the same rate as when there is no key inserted.
    The ECM does not set any trouble codes.
    The immobilizer module sets a B2796 and/or B2798
    As soon as a valid key is inserted everything works normally.

    Below are screenshots of the relevant data PIDs from both the Immobilizer and the ECM.

    The codes.
    20220115_171843.jpg 20220115_174559.jpg


    Immoblizer data with a bad key.
    20220115_173438.jpg

    Immobilizer data with a good key.
    20220115_173506.jpg

    ECM data Immobilizer PIDs bad key.
    20220115_174112.jpg

    ECM data Immobilizer PIDs good key.
    20220115_174134.jpg
     
    Torspd, PzTank, Jimmyh and 2 others like this.
  6. Jan 15, 2022 at 4:19 PM
    #66
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    8,336
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    Nice. :thumbsup:
    So, would it be safe to say the ECM is not sending control to fire the injectors?
    Since the EFI fuse is powered?
     
  7. Jan 15, 2022 at 4:22 PM
    #67
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    8,336
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    Never mind, all the pictures loaded for me.
    I see the ECM PIDs.

    Now we know. Thanks man:thumbsup:
     
  8. Jan 15, 2022 at 4:23 PM
    #68
    Dm93

    Dm93 Test Don't Guess

    Joined:
    Mar 3, 2015
    Member:
    #150066
    Messages:
    3,167
    Gender:
    Male
    Texas
    Vehicle:
    2014 DC OR 6spd 4x4
    Predator tube steps, Ranch Hand grill guard, Magnaflow CatBack exhaust, Toyota tool box & bed mat, 2LO Module by @Up2NoGood, Rearview Compass/Temp Mirror.
    I would assume this is the case as that's how most immobilizer systems work, some disable the starter in addition to the injectors.
     
    TnShooter likes this.
  9. Jan 15, 2022 at 4:28 PM
    #69
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    8,336
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    I found out what else will disable a vehicle and me today.
    Trying to shove a plug through a 10 ply tire, while on your back, with tire still on the truck.
     
    dk_crew and Jimmyh like this.
  10. Jan 15, 2022 at 4:35 PM
    #70
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    8,336
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    @Dm93 did you check power on the 10A EFI No.2 fuse also.
    Or just the 20A EFI? 20A EFI is straight from battery?

    I’m still wondering why the diagram shows the EFI relay.
    Why would they include that if it didn’t do anything? Weird?
     
  11. Jan 15, 2022 at 4:39 PM
    #71
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    8,336
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    Taking a better look, maybe it is because the EFI relay also powers the ECU?
    I don’t know?
     
  12. Jan 15, 2022 at 4:45 PM
    #72
    Dm93

    Dm93 Test Don't Guess

    Joined:
    Mar 3, 2015
    Member:
    #150066
    Messages:
    3,167
    Gender:
    Male
    Texas
    Vehicle:
    2014 DC OR 6spd 4x4
    Predator tube steps, Ranch Hand grill guard, Magnaflow CatBack exhaust, Toyota tool box & bed mat, 2LO Module by @Up2NoGood, Rearview Compass/Temp Mirror.
    That fuse is labeled EFI on my 14, the EFI relay powers the COPN (fuel pump on/off) relay, various solenoids, part of the ECM, MAF sensor, and oxygen sensor heaters.
    As to why it shows up on the Immobilizer diagram who knows.
     
  13. Jan 15, 2022 at 4:55 PM
    #73
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    8,336
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    Yeah, who know.
    I know under the 1GR control diagram is shows the No.2 fuse.
    But not on the immobiler?

    1D481EF0-565F-40A3-9EAB-65BEBA447CFB.jpg 3F5BF699-432F-49B3-9FE9-814CEC7A6F68.jpg
     
    FishaRnekEd [OP] likes this.
  14. Jan 17, 2022 at 7:25 AM
    #74
    FishaRnekEd

    FishaRnekEd [OP] Well-Known Member

    Joined:
    Dec 11, 2013
    Member:
    #118381
    Messages:
    707
    Gender:
    Male
    New Orleans, LA
    Vehicle:
    2005 4.0 6spd 4x4 Dbl Cb short bed
    Well, I'm going to say my truck is fixed now.

    My problem ended up being an issue between the computer and imobilizer. The hard reset on the computer fixed it.

    I think between my mechanical fixes and you two figuring out how the imobilizer cuts off the fuel, we have covered most of the possibilities for the crank crank crank no start problems.

    Mods, i would like to suggest this thread as a sticky, to help people searching in the future.
     
  15. Jan 17, 2022 at 9:25 AM
    #75
    Taco'09

    Taco'09 Well-Known Member

    Joined:
    Dec 31, 2008
    Member:
    #12073
    Messages:
    1,785
    Gender:
    Male
    @Daria
    Sticky Please for This Important Thread!
     
  16. Jan 18, 2022 at 5:15 AM
    #76
    FishaRnekEd

    FishaRnekEd [OP] Well-Known Member

    Joined:
    Dec 11, 2013
    Member:
    #118381
    Messages:
    707
    Gender:
    Male
    New Orleans, LA
    Vehicle:
    2005 4.0 6spd 4x4 Dbl Cb short bed
    Note- between cleaning the tank, complete fuel system, new pump and cleaning the entire air intake (also resetting the computer) i think i have full power!!! I didn't really notice a loss until i got the power back.

    I'm guessing it was about 10-15% down. I was only getting about 230 miles before i hit 1/8 tank and had to fill up. I think i used to go 280 miles before filling up. (Smallest gas tank in any truck I've ever had).
     
  17. Jan 18, 2022 at 5:34 AM
    #77
    PzTank

    PzTank Stuck in the Well

    Joined:
    Sep 14, 2010
    Member:
    #43250
    Messages:
    3,828
    First Name:
    Jim
    New England
    Vehicle:
    ‘15 AC SR5 4X4 4.0 Auto - Silver Sky
    ‘07 OR leather shift knob.
    If he’s going to put himself through that, might as well
    https://performanceparts.ford.com/part/M-6007-M52SC :D
     
    Larzzzz likes this.
  18. Jan 18, 2022 at 8:29 AM
    #78
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    8,336
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    Larzzzz, PzTank and Dm93 like this.
  19. Mar 1, 2022 at 4:55 AM
    #79
    FishaRnekEd

    FishaRnekEd [OP] Well-Known Member

    Joined:
    Dec 11, 2013
    Member:
    #118381
    Messages:
    707
    Gender:
    Male
    New Orleans, LA
    Vehicle:
    2005 4.0 6spd 4x4 Dbl Cb short bed
    update-. everything is good. it was definitely the computer/key/imobilizer.

    also, with a new pump and fuel filter, I'm noticing that the truck was about %10 low on power (i would not have noticed this, but now it definitely has full power)

    I'm still not getting good gas mileage, but that's probably the shit New Orleans roads and idiots that make me brake/accelerate for no reason. and my lead foot...
     
    Torspd, TnShooter and Dm93 like this.

Products Discussed in

To Top