1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Front radar (TSS) sensor error

Discussion in '3rd Gen. Tacomas (2016+)' started by polloloco81, Mar 6, 2019.

  1. Mar 6, 2019 at 9:44 AM
    #1
    polloloco81

    polloloco81 [OP] Well-Known Member

    Joined:
    Jun 18, 2018
    Member:
    #256768
    Messages:
    238
    Gender:
    Male
    First Name:
    MH
    Vehicle:
    2018 Tacoma TRD Off-Road 4x4
    I know there's several threads on this regarding the error people are receiving whenever they swap into a TRD Pro Grille, but I want to start a thread on how people that received the error are able to fix it.

    -Did you guys get the error at all when you swapped over to the Pro grille?
    -If you didn't get the error, was it because you got the OEM garnish vs. aftermarket?
    -If you get the error, did the error go away after a few days of driving?
    -Did you guys have to bring your truck back to the dealership to get the sensor re-calibrated?

    Just out of curiosity, I called several Toyota dealerships in my area and asked if they are able to 're-calibrate' my sensor. All said they are able to do it, and one dealership said it'll cost $280 and half a day for them to re-calibrate. If it'll cost me $280 just to recalibrate, I'd rather take the sensor out of the car and replace the garnish with the original grille part.

    It seems like the sensor error only affects the brake assist and the cruise control assist. The lane departure still works fine. Are there any other safety features associated with this sensor that I'm unaware of? I personally don't care for brake/cruise control assist, I'd rather drive with those things disabled, but I also prefer things working properly in my truck.

    Would love to hear everyone's input, especially those that have encountered this same issue with the TSS sensor!
     
  2. Mar 6, 2019 at 9:49 AM
    #2
    Tacoma1818

    Tacoma1818 Well-Known Member

    Joined:
    Feb 2, 2017
    Member:
    #209442
    Messages:
    595
    Gender:
    Male
    No error. China grille, oem sensor garnish piece.

    Did you get the garnish?
     
    2dab likes this.
  3. Mar 6, 2019 at 9:59 AM
    #3
    polloloco81

    polloloco81 [OP] Well-Known Member

    Joined:
    Jun 18, 2018
    Member:
    #256768
    Messages:
    238
    Gender:
    Male
    First Name:
    MH
    Vehicle:
    2018 Tacoma TRD Off-Road 4x4
    I got an aftermarket garnish. I have an OEM in my shopping cart, I'll probably buy it in a few more weeks to give it a shot if I know having the OEM will do the trick.

    Also, how do you know if you have the OEM garnish? The OEM garnish I'm looking at is on Amazon.com, there's not a lot of info on the product page so I just want to make sure I'm not buying some fake stuff.
     
  4. Mar 6, 2019 at 10:02 AM
    #4
    TnTuna

    TnTuna Well-Known Member

    Joined:
    Feb 7, 2019
    Member:
    #282181
    Messages:
    157
    Gender:
    Male
    Vehicle:
    3rd Gen Tacoma
    I have the oem pro grille and oem garnish. Only had one error due to rough weather conditions.
     
  5. Mar 6, 2019 at 10:08 AM
    #5
    EnBoo

    EnBoo Well-Known Member

    Joined:
    Jul 16, 2018
    Member:
    #259519
    Messages:
    397
    Gender:
    Male
    First Name:
    Nathan
    Denver, CO
    Vehicle:
    2018 DCSB Quicksand Sellout
    Fake grill, oem garnish and no errors here. Sounds stupid but make sure all of the connections on the cables are secure if you haven't already.
     
    2dab likes this.
  6. Mar 6, 2019 at 10:46 AM
    #6
    Tacoma1818

    Tacoma1818 Well-Known Member

    Joined:
    Feb 2, 2017
    Member:
    #209442
    Messages:
    595
    Gender:
    Male

    I got mine from eBay from a dealership. When I did it, there were no such thing as aftermarket garnish pieces so I didn’t have a choice. It was like $50 — so that’s one way to tell... price. Another is looking for a genuine oem part number:
    53141-35060
     
    polloloco81 [OP] likes this.
  7. Mar 6, 2019 at 11:16 AM
    #7
    dal3_gribble

    dal3_gribble Well-Known Member

    Joined:
    Apr 14, 2018
    Member:
    #250494
    Messages:
    1,203
    Vehicle:
    Crew Cab SB TRD Offroad
    I did see a few false positives with TSS, with the BRAKE warning happening a few times. It did seem to be tied to the grille and hasn't happened since. It may false positive, but otherwise it seems accurate still.

    I would never trust the TSS anyways and the adaptive cruise control is terrible, so I'm not worried about it.
     
  8. Mar 6, 2019 at 11:51 AM
    #8
    tacothyme

    tacothyme Well-Known Member

    Joined:
    Apr 22, 2015
    Member:
    #153709
    Messages:
    224
    Gender:
    Male
    First Name:
    Cory
    Seattle, WA
    Vehicle:
    18 DCLB OR
    265/70/17
    fake grill, no garnish. black plastic plate between radar and grill plug. similar to this: https://www.tacomaworld.com/threads...p-radar-info-diy.530769/page-48#post-18470874

    There were some errors for the first couple hundred miles. (So I picked up the OEM garnish - just in case). But making sure the plate between the radar sensor and the grill plug was 100% vertical and clean, plus some relearning time resolved any issues. 6k miles later and some very harsh weather - no problems.
     
    Last edited: Mar 6, 2019
    JNewton99 and polloloco81 [OP] like this.
  9. Mar 6, 2019 at 7:22 PM
    #9
    Jrive01a

    Jrive01a Well-Known Member

    Joined:
    Mar 6, 2019
    Member:
    #285664
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2019 toyota tacoma
    I'm having error problem with mine after 2 days of aftermarket trd pro grille install. Help!
     
  10. Mar 6, 2019 at 7:44 PM
    #10
    19cement4xor

    19cement4xor Well-Known Member

    Joined:
    Jan 2, 2019
    Member:
    #277867
    Messages:
    65
    Gender:
    Male
    First Name:
    Eric
    Clear Lake TX
    Vehicle:
    19 Cement Trd off road 4x4
    TRD Pro suspension, Method Nv, 265/70-17 bfg ko2, meso TRD center caps
    All oem , error only during very heavy rain at hwy speeds but it goes away as rain lets up.
     
  11. Mar 6, 2019 at 8:03 PM
    #11
    Jrive01a

    Jrive01a Well-Known Member

    Joined:
    Mar 6, 2019
    Member:
    #285664
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2019 toyota tacoma
    I bought knockoff garnish. Looks very nice but keep getting error. I might give it some time and see if it goes away if not I moght try the license plate plastic cutout method.
     
  12. Mar 7, 2019 at 12:13 AM
    #12
    Kodthree

    Kodthree Active Member

    Joined:
    Jul 14, 2018
    Member:
    #259272
    Messages:
    29
    Gender:
    Male
    First Name:
    Kody
    Vehicle:
    2018 DC TRD OR
    INCOMING!
    I was getting error after error. All OEM equipment.
    Dealer diagnosed and replaced defective millimeter wave (TSS) sensor under warranty at 3100 miles. I think these things are prone to water intrusion, especially after high pressure automatic car washes... and mine gets these weekly at least.
    You all might want to consider this as a concurrent problem.
    Kodthree out...
     
    King Kermit V likes this.
  13. Mar 7, 2019 at 6:46 AM
    #13
    Jrive01a

    Jrive01a Well-Known Member

    Joined:
    Mar 6, 2019
    Member:
    #285664
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2019 toyota tacoma
    I was having light come on every now and then with original grille. Might put old one back and take to dealer if it continues. I'm at 900 miles only.
     
  14. Mar 7, 2019 at 7:04 AM
    #14
    Norsemanvike

    Norsemanvike Well-Known Member

    Joined:
    Feb 15, 2018
    Member:
    #244562
    Messages:
    4,840
    Gender:
    Male
    Escondido, CA
    Vehicle:
    '18 Sport 4x4, DblCb, ShBd, BBP
    Q1) Did you guys get the error at all when you swapped over to the Pro grille?
    A1) No errors at all.

    Q2) If you didn't get the error, was it because you got the OEM garnish vs. aftermarket?
    A) Used after market garnish.

    Q3) If you get the error, did the error go away after a few days of driving?
    A3) N/A

    Q4) Did you guys have to bring your truck back to the dealershipto get the sensor re-calibrated?
    A4) No.

    I purchased both from @FreshMexicanTaco .
     
    Jrive01a likes this.
  15. Mar 7, 2019 at 4:06 PM
    #15
    2dab

    2dab Active Member

    Joined:
    Jan 30, 2019
    Member:
    #281203
    Messages:
    43
    Gender:
    Male
    California, Bay Area
    2019 Tacoma Trd Off Road Metallic Grey DCLB
    knock on woody, i got a oem garnish and china man grill. i also put hot glue drops in the top tabs of the garnish inside just to secure it extra, it seemed kinda loose. not one error yet have driven 300 miles with all the TSS working fine in the rain.
     
    YE2KA likes this.
  16. Mar 9, 2019 at 11:50 AM
    #16
    polloloco81

    polloloco81 [OP] Well-Known Member

    Joined:
    Jun 18, 2018
    Member:
    #256768
    Messages:
    238
    Gender:
    Male
    First Name:
    MH
    Vehicle:
    2018 Tacoma TRD Off-Road 4x4
    After driving for a week, I was getting tired of the error, so I ended up ordering an OEM garnish from Amazon to replace my aftermarket. The funny thing is that even after I disabled the pre-collision option, it comes back on every time I turn my car on.

    I've only driven for about 10 miles, but so far no error. I'll do some more driving this weekend to report back. The error usually pops on after 1 or 2 miles driving.
     
  17. Mar 19, 2019 at 12:47 PM
    #17
    Jrive01a

    Jrive01a Well-Known Member

    Joined:
    Mar 6, 2019
    Member:
    #285664
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2019 toyota tacoma
    Any update on the OEM garnish? Has the tss light come on?
     
  18. Mar 19, 2019 at 12:55 PM
    #18
    mds08

    mds08 Senior member

    Joined:
    Mar 26, 2018
    Member:
    #248467
    Messages:
    2,510
    Gender:
    Male
    Parts Unknown
    2018 Silver Sky double cab longbed
    What error are you guys getting? The loud beep saying break or the one under the tach that says off. I got the one that says off and it stayed on for about 10 second on two occasions. That was it, never a false alarm for me to break.
     
  19. Mar 19, 2019 at 1:00 PM
    #19
    mds08

    mds08 Senior member

    Joined:
    Mar 26, 2018
    Member:
    #248467
    Messages:
    2,510
    Gender:
    Male
    Parts Unknown
    2018 Silver Sky double cab longbed
    I
    I have all OEM parts and got the off light. That's it and it's been about four months ago.
     
  20. Mar 19, 2019 at 3:19 PM
    #20
    Jrive01a

    Jrive01a Well-Known Member

    Joined:
    Mar 6, 2019
    Member:
    #285664
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2019 toyota tacoma
    I get the off warning on the dash after like 3 miles of driving after each startup
     
To Top