1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Maint Reqd light.

Discussion in '2nd Gen. Tacomas (2005-2015)' started by rpoint16, May 30, 2009.

  1. May 30, 2009 at 9:38 AM
    #1
    rpoint16

    rpoint16 [OP] Well-Known Member

    Joined:
    Sep 2, 2007
    Member:
    #2588
    Messages:
    575
    Gender:
    Male
    Tempe, AZ
    Vehicle:
    2008 double cab, 4X4, V-6, TRD. Super White.
    OME 885 coils & front shocks, with TT top plate, Total Chaos UCA, Rear OME extended shocks, Rear TSB, Rear Toytec AAL, trimmed the saber-tooth-tiger-long-ass mud flaps. 17" XD Revolver rims, 265/75/17 BFG AT KO's. Ripped out the crappy FM Modulator & installed a PA-15-toy interface. OEM bed matt.
    I have 20K miles on my Taco. My first oil change was at 3K, then every 4-5K w/ mobil 1.

    200 miles after my last oil change my "maint reqd" light came on. Not knowing what it was, I looked it up in my manual & it is the oil change reminder & reset it.

    I obviously never heard about it, & have never reset it. What's the dealio:confused:
     
  2. May 30, 2009 at 9:39 AM
    #2
    Brunes

    Brunes abides.

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,641
    Gender:
    Male
    First Name:
    Rotorhead
    DC or New Jersey - Depends on the day....
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit
    Check out the Mods and Tutorials menu at the top of the site- it's got a section all about the light.
     
  3. May 30, 2009 at 9:49 AM
    #3
    ForeRunner

    ForeRunner Scotch before noon. Moderator

    Joined:
    Sep 9, 2006
    Member:
    #7
    Messages:
    12,104
    Gender:
    Male
    First Name:
    Drunken Sailor
    Somewhere between Maine and Florida
    Vehicle:
    2016 Subaru WRX STI Limited (no wing)
    Extra PSI
  4. May 30, 2009 at 9:52 AM
    #4
    rpoint16

    rpoint16 [OP] Well-Known Member

    Joined:
    Sep 2, 2007
    Member:
    #2588
    Messages:
    575
    Gender:
    Male
    Tempe, AZ
    Vehicle:
    2008 double cab, 4X4, V-6, TRD. Super White.
    OME 885 coils & front shocks, with TT top plate, Total Chaos UCA, Rear OME extended shocks, Rear TSB, Rear Toytec AAL, trimmed the saber-tooth-tiger-long-ass mud flaps. 17" XD Revolver rims, 265/75/17 BFG AT KO's. Ripped out the crappy FM Modulator & installed a PA-15-toy interface. OEM bed matt.
    I read thru that & it's good info.

    The reason for my post is to determine why, after 19.5K miles it came on for the first time:confused:

    Wondering if anyone else has had this happen.
     
  5. May 30, 2009 at 10:02 AM
    #5
    ForeRunner

    ForeRunner Scotch before noon. Moderator

    Joined:
    Sep 9, 2006
    Member:
    #7
    Messages:
    12,104
    Gender:
    Male
    First Name:
    Drunken Sailor
    Somewhere between Maine and Florida
    Vehicle:
    2016 Subaru WRX STI Limited (no wing)
    Extra PSI
    Have you been taking it to the dealer for the oil changes? If so they have probably been resetting it for you. If not and you have been doing them yourself, then I have no idea why it didn't pop up sooner. It does not sense the condition of the oil and it is solely based upon miles driven.
     
  6. May 30, 2009 at 10:05 AM
    #6
    rpoint16

    rpoint16 [OP] Well-Known Member

    Joined:
    Sep 2, 2007
    Member:
    #2588
    Messages:
    575
    Gender:
    Male
    Tempe, AZ
    Vehicle:
    2008 double cab, 4X4, V-6, TRD. Super White.
    OME 885 coils & front shocks, with TT top plate, Total Chaos UCA, Rear OME extended shocks, Rear TSB, Rear Toytec AAL, trimmed the saber-tooth-tiger-long-ass mud flaps. 17" XD Revolver rims, 265/75/17 BFG AT KO's. Ripped out the crappy FM Modulator & installed a PA-15-toy interface. OEM bed matt.
    I went to the dealer the first time because I could not get my oil filter off (that's another story, I broke two filter wrenches). Since then though I do my own. Kinda wierd, but no biggie.
     
  7. May 30, 2009 at 10:06 AM
    #7
    Pster

    Pster Well-Known Member

    Joined:
    Jun 30, 2008
    Member:
    #7654
    Messages:
    2,745
    Gender:
    Male
    Charlotte, NC
    Vehicle:
    2006 Tacoma 4x4
    Bak Flip bed cover, shorty antenna, Peripheral iPod interface, Garmin 750 mount, add'l bed tie down rings, Westin nerf bars, hitch safe, tailgate lock, Ideal 1 3/4" turn-key clamp to secure tailgate from removal, Spare tire security cable, spare tire stainless air hose extender, Fumoto oil drain valve, Amp Research Bed X-Tender w/Schlage Cable Lock, bed mat, Redline hood struts
    I think the manual says hold your breath for 2 minutes while rubbing your stomach with your left and with your right hand turn the key to accessory and off 5 times while pressing on the brake pedal with the radio set to channel 88.8. That should turn off the "dealer sales rep full employment act" light.
     
To Top