1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Overhead console w/temp and compass not working

Discussion in 'Technical Chat' started by Armyballer, May 6, 2009.

  1. May 6, 2009 at 12:44 PM
    #1
    Armyballer

    Armyballer [OP] Well-Known Member

    Joined:
    Mar 27, 2009
    Member:
    #15203
    Messages:
    70
    Gender:
    Male
    Alabama
    Vehicle:
    05 4x4TRD
    Got into my truck today and noticed it was no longer working (no lights). My first guess is possibly a fuse. However, the map lights work fine. Anyone with some other insight? I'll check the fuses today when I get home.

    05 DC TRD btw.
     
  2. May 6, 2009 at 12:50 PM
    #2
    bcash9407

    bcash9407 Member

    Joined:
    Apr 30, 2009
    Member:
    #16627
    Messages:
    14
    Gender:
    Male
    Buena Vista, VA
    Vehicle:
    06 Tacoma
    Flowmaster 40 Series
    Mine is the same way, it was like that when I bought the truck off of a local. Not sure what the fix is. I asked the previous owner and he told me that it happened after a year of owning the truck, he said that he had it checked out by Toyota and that it would cost like $350 to fix. He didn't even tell me what would actually have to be replaced though. Im not sure if he is correct or not, he may even be making the entire thing up. But all in all I myself didn't think it was worth $350 to fix it. Not that big of a deal to me. However if anyone else has a fix, or any suggestions please let us know.
    Let me know how it goes chief...
     
  3. May 6, 2009 at 12:52 PM
    #3
    Armyballer

    Armyballer [OP] Well-Known Member

    Joined:
    Mar 27, 2009
    Member:
    #15203
    Messages:
    70
    Gender:
    Male
    Alabama
    Vehicle:
    05 4x4TRD

    $350.00!!! WTF, I've seen the entire piece for sale on this very site for $150.00. Damn, I really like the outside temp feature, may have to look at replacing it.
     
  4. May 6, 2009 at 12:53 PM
    #4
    Dark Knight

    Dark Knight Well-Known Member

    Joined:
    Jul 18, 2008
    Member:
    #8006
    Messages:
    9,594
    Gender:
    Male
    First Name:
    Jeff
    NC/SC
    Vehicle:
    4Runner Trail
  5. May 6, 2009 at 12:53 PM
    #5
    tacoskim

    tacoskim Tuned By Gadget

    Joined:
    Mar 13, 2008
    Member:
    #5252
    Messages:
    2,385
    Gender:
    Male
    Los Angeles, CA
    Vehicle:
    09 TRD 4x4 Pyrite Mica
    Stock
    its an easy fix, should take no longer than 30 mins. take it out, solder the fuse and ur done
     
  6. May 6, 2009 at 2:04 PM
    #6
    johnecon2001

    johnecon2001 Well-Known Member

    Joined:
    Apr 26, 2009
    Member:
    #16456
    Messages:
    1,019
    Gender:
    Male
    Phoenix, AZ
    Vehicle:
    2005 TRD Sport 4x4 Access Cab
    Downey front skid, Trail Gear U-Bolt flip, Toytec AAL, Total Chaos UCA's, Bilstein 5100's x4 + Eibach adjustable coils, Doug Thorley Long Tube Headers, Custom Rear bumper, TRD OffRoad front tow hook, TRD Trail Team wheels, Federal Couragia M/T 265's, ARB rear locker + on board air (CKMA12), TRD shift knob, Alpine W205, TRD seat covers, Tom Woods 1 Piece drive shaft, Powermaster D2700, Stubbs HD-SKO Sliders.
    If you're too scared to do it yourself.. send it to me with $30. I'll do it for you.
     
  7. May 6, 2009 at 6:23 PM
    #7
    bcash9407

    bcash9407 Member

    Joined:
    Apr 30, 2009
    Member:
    #16627
    Messages:
    14
    Gender:
    Male
    Buena Vista, VA
    Vehicle:
    06 Tacoma
    Flowmaster 40 Series
    great posts you guys....works like a charm...saves $$$$$
     
To Top