1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Scangauge or Ultragauge incompatibilities?

Discussion in '1st Gen. Tacomas (1995-2004)' started by gshephard, Jun 3, 2013.

  1. Jun 3, 2013 at 5:56 PM
    #1
    gshephard

    gshephard [OP] Member

    Joined:
    Nov 24, 2011
    Member:
    #67615
    Messages:
    8
    Gender:
    Male
    First Name:
    Glen
    San Diego County
    Vehicle:
    01 Tacoma 2.7L 4WD
    K&N Intake
    I'm considering purchasing a scangauge or an ultragauge. The Ultragauge website said that some vehicles have incompatibilities with the UG. My vehicle, 2001 Taco 2.7L, 4WD is listed as one of them. The website says that by disconnecting a couple of pins in the ODBII cable, the problem is solved.

    Has anyone encountered this, does Scangauge have the same problem or is it a turnkey solution?

    The symptom listed on the UG website is that UG turns off the ABS system causing the error light to turn on unless a couple pins are disconnected.

    I'd appreciate any help. The UG price is below the level of interest of my wife but the scangauge is above it.
     
  2. Jun 3, 2013 at 7:19 PM
    #2
    bellassaiw10

    bellassaiw10 Formally afroman5015

    Joined:
    Jun 16, 2010
    Member:
    #39032
    Messages:
    4,944
    Gender:
    Male
    Currituck NC
    Vehicle:
    00 4WD Prerunner
    There multiple threads on this.... But I do know the UG does have to have the pins removed for the 01-04s But members on here have done it and been satisfied. I do not have ABS but love my UG
     
  3. Jun 3, 2013 at 7:27 PM
    #3
    Taylor

    Taylor Wants to learn all about his Taco.

    Joined:
    Mar 7, 2012
    Member:
    #74417
    Messages:
    1,271
    Gender:
    Male
    First Name:
    Taylor
    Lynchburg/Harrisonburg Virginia
    Vehicle:
    03 4x4 TRD SR5 College build
    Extra badges, painted skidplates, grey wire mod, Kenwood double-DIN headunit, pioneer amp, 12 inch MTX sub, playstation 2 under seat, Uniden CB with 5 foot Wilson 1000 antenna, deckplate mod, 4xinnovations sliders, diff breather mod, bilstein 5100s at all 4 corners, OME Dakar Leaves, BAMF BPV bracket, Wheelers greasable shackles,
    What doesn't work? I got my UG today and the only thing that doesn't seem to work is the fuel sender.
     
  4. Jun 3, 2013 at 7:31 PM
    #4
    TacoSkeet

    TacoSkeet 'MERICA

    Joined:
    Oct 16, 2012
    Member:
    #89164
    Messages:
    669
    Gender:
    Male
    First Name:
    Steven
    Memphis, TN
    Vehicle:
    03 DC Tacoma
    If you have ABS and you dont modify the UG, then it will flash the "ABS" light.

    All you do is pop a red wire out of the OBDI and you're set
     
  5. Jun 3, 2013 at 7:54 PM
    #5
    Taylor

    Taylor Wants to learn all about his Taco.

    Joined:
    Mar 7, 2012
    Member:
    #74417
    Messages:
    1,271
    Gender:
    Male
    First Name:
    Taylor
    Lynchburg/Harrisonburg Virginia
    Vehicle:
    03 4x4 TRD SR5 College build
    Extra badges, painted skidplates, grey wire mod, Kenwood double-DIN headunit, pioneer amp, 12 inch MTX sub, playstation 2 under seat, Uniden CB with 5 foot Wilson 1000 antenna, deckplate mod, 4xinnovations sliders, diff breather mod, bilstein 5100s at all 4 corners, OME Dakar Leaves, BAMF BPV bracket, Wheelers greasable shackles,
    Hmm... interesting. I guess I haven't driven enough to get it. I drove to the gas station and back and didn't notice my ABS light.

    Is it just the light that goes off? I think I could deal with that.
     
  6. Jun 3, 2013 at 9:14 PM
    #6
    Norton

    Norton Senior TW Member

    Joined:
    Mar 10, 2011
    Member:
    #52729
    Messages:
    2,024
    Gender:
    Male
    First Name:
    Steve
    Monument, CO
    Vehicle:
    04 V6 5-Spd SR5 TRD 4x4
    TRD Supercharger; URD 7th Injector; Injen CAI w/Airaid SynthaMax Filter; Magnaflow Cat-back; Light Racing UCAs, Wheelers 5-Leafs; OME 881s; Bilstein 5100s; Goodridge SS Brake Lines; Goodyear Wrangler Duratracs on 4Runner Ltd 5-Spokes; MetalMiller TRD Skid; B.A.M.F BPV Bracket; Grey Wire, Fog Light, Power Outlet, Door Chime & DRL Mods; FUBAR Moto Bits LED Headlights; Interior, Under-hood, & Reverse LEDs; Kenwood KDC-X895 HU & KFC-C6893PS Spkrs, Sound Ordnance B-8PT Sub & Dynamat; Husky Floor Liners; UltraGauge EM; External Thermometer; Redline Tuning QuickLIFT Elite; Rhino Bed Liner; Toyota Bed Extender; SnugTop Super Sport; SolarGard Tint; CravenSpeed Stubby Antenna; Alarm w/Keyless Entry; Amsoil Lubricants; Adam's Detailing Supplies
    The light flashing indicates ABS is in a diagnostic mode that DISABLES it until you shut the truck off, disconnect the UG, start the truck, and re-connect the UG.

    FWIW, I have NOT disconnected any pins and I rarely have this problem. It seems to occur only when the truck is slow to start (i.e., a few extra cranks with the starter). When it starts normally, I have NO problems with UG/ABS compatibility. (I realize this sounds strange, but it's been my experience since I installed the UG over a year ago.)
     
  7. Jun 4, 2013 at 6:24 AM
    #7
    MowTaco

    MowTaco Well-Known Member

    Joined:
    Sep 9, 2009
    Member:
    #22530
    Messages:
    3,824
    Gender:
    Male
    First Name:
    Matt
    South Dakota
    Vehicle:
    03 GMC Sierra
    I'm quite sure that it in no way effects the ABS system. It just puts it into a diagnostic mode and flashes the ABS light intermittently (although I have yet to figure out exactly what causes it to flash, it seems to be random as long as something is plugged into the OBD port). My ABS system still functions perfectly normally with the light flashing and the flashing doesn't really bother me so I've left it alone
     
  8. Jun 4, 2013 at 7:10 AM
    #8
    Taylor

    Taylor Wants to learn all about his Taco.

    Joined:
    Mar 7, 2012
    Member:
    #74417
    Messages:
    1,271
    Gender:
    Male
    First Name:
    Taylor
    Lynchburg/Harrisonburg Virginia
    Vehicle:
    03 4x4 TRD SR5 College build
    Extra badges, painted skidplates, grey wire mod, Kenwood double-DIN headunit, pioneer amp, 12 inch MTX sub, playstation 2 under seat, Uniden CB with 5 foot Wilson 1000 antenna, deckplate mod, 4xinnovations sliders, diff breather mod, bilstein 5100s at all 4 corners, OME Dakar Leaves, BAMF BPV bracket, Wheelers greasable shackles,
    I think I'll leave it. Does anyone have a link to the port mod just in case?
     
  9. Jun 4, 2013 at 7:35 AM
    #9
    BigOly

    BigOly Well-Known Member

    Joined:
    May 3, 2012
    Member:
    #78148
    Messages:
    417
    Gender:
    Male
    Bay Area, NorCal
    Vehicle:
    04 TRD DC V6 SR5 4WD
    I used to own both but sold the UltraGuage (UG) and kept the ScanGuage (SG) ONLY because the UG does not support the monitoring of transmission temperature, the SG WILL read trans temp using the X-gauge feature (your SG needs to have the latest firmware to program trans temp in) and must be a later model 1st gen when toyota began offering it via ODBII. If UG ever updates their firmware to monitor transmission temp I will switch over. I LOVE the alarm alerts on the UG and it has a very accurate DTE (distance till empty) feature that I miss using and that the SG lacks.


    The ScanGauge (SG) DOES trigger the ABS indicator to blink as well, same symptom as the UltraGauge (UG). I spoke with the SG folks and they sent me a modified cable (they call it an ISO cable) that fixes the ABS blinking problem. With some social engineering skills (being nice and honest with them) they sent me a modified cable free of charge and it fixed the problem. They also let me keep my original SG cable which I have plugged in my other vehicle that doesn't have this problem. It's nice to be able to unplug the SG over to another vehicle (not fixed like the UG). The scangauge folks are top notch with their customer service! Can't tell you much about the UG folks as they make you jump hoops with rebates and a crazy web supported CS system. The modified cable is simply a scangauge ODBII cable with a couple of missing pins. From what I was told, and to somewhat reiterate Mowtaco's earlier post, the missing pins (modified cable) are what trigger the diagnostics testing in the system causing the ABS indicator issue with the later 1st gen tacos.
     
    Last edited: Jun 4, 2013
  10. Jun 4, 2013 at 7:41 AM
    #10
    BigOly

    BigOly Well-Known Member

    Joined:
    May 3, 2012
    Member:
    #78148
    Messages:
    417
    Gender:
    Male
    Bay Area, NorCal
    Vehicle:
    04 TRD DC V6 SR5 4WD
    I think TimmyB already posted the solution on this thread.

    ProForce also has a good writeup from the group buy thread: HERE
     
  11. Jun 4, 2013 at 7:58 AM
    #11
    Taylor

    Taylor Wants to learn all about his Taco.

    Joined:
    Mar 7, 2012
    Member:
    #74417
    Messages:
    1,271
    Gender:
    Male
    First Name:
    Taylor
    Lynchburg/Harrisonburg Virginia
    Vehicle:
    03 4x4 TRD SR5 College build
    Extra badges, painted skidplates, grey wire mod, Kenwood double-DIN headunit, pioneer amp, 12 inch MTX sub, playstation 2 under seat, Uniden CB with 5 foot Wilson 1000 antenna, deckplate mod, 4xinnovations sliders, diff breather mod, bilstein 5100s at all 4 corners, OME Dakar Leaves, BAMF BPV bracket, Wheelers greasable shackles,
    Whoops, my bad, I didn't see that. Thanks!
     
  12. Jun 4, 2013 at 9:14 AM
    #12
    Norton

    Norton Senior TW Member

    Joined:
    Mar 10, 2011
    Member:
    #52729
    Messages:
    2,024
    Gender:
    Male
    First Name:
    Steve
    Monument, CO
    Vehicle:
    04 V6 5-Spd SR5 TRD 4x4
    TRD Supercharger; URD 7th Injector; Injen CAI w/Airaid SynthaMax Filter; Magnaflow Cat-back; Light Racing UCAs, Wheelers 5-Leafs; OME 881s; Bilstein 5100s; Goodridge SS Brake Lines; Goodyear Wrangler Duratracs on 4Runner Ltd 5-Spokes; MetalMiller TRD Skid; B.A.M.F BPV Bracket; Grey Wire, Fog Light, Power Outlet, Door Chime & DRL Mods; FUBAR Moto Bits LED Headlights; Interior, Under-hood, & Reverse LEDs; Kenwood KDC-X895 HU & KFC-C6893PS Spkrs, Sound Ordnance B-8PT Sub & Dynamat; Husky Floor Liners; UltraGauge EM; External Thermometer; Redline Tuning QuickLIFT Elite; Rhino Bed Liner; Toyota Bed Extender; SnugTop Super Sport; SolarGard Tint; CravenSpeed Stubby Antenna; Alarm w/Keyless Entry; Amsoil Lubricants; Adam's Detailing Supplies
    Definitely NOT my experience. In fact, I used the ABS-disabling behavior when teach my 15 year old son how ABS works a few months ago. When not flashing ABS engaged properly when triggered. When flashing, ABS did NOT engage. Also, there's nothing "random" about how mine flashes. When this happens, it flashes rapidly/steadily/constantly until reset as I described above.
     
  13. Jun 4, 2013 at 9:27 AM
    #13
    127.0.0.1

    127.0.0.1 AKA ::1

    Joined:
    Dec 24, 2012
    Member:
    #93641
    Messages:
    1,693
    Gender:
    Male
    /etc/hosts
    Vehicle:
    2013 NBM AC 4.0 4x4 Auto OR
    lol wut ? I have distance to empty on all three SG I have...

    you just send a tank gauge to x-gauge and bam, distance to empty
    ---------------------
    operate sg same as usual, just

    a) fill to first click
    and
    b) enter amount pumped in fillup setting
     
  14. Jun 4, 2013 at 11:17 AM
    #14
    BigOly

    BigOly Well-Known Member

    Joined:
    May 3, 2012
    Member:
    #78148
    Messages:
    417
    Gender:
    Male
    Bay Area, NorCal
    Vehicle:
    04 TRD DC V6 SR5 4WD
    Sorry about that, bad wording on my part, so let me clarify the part about DTE to avoid any confusion:

    The SG can do DTE but it is not as accurate as the UG. The SG only allows you to program your tank size in whole #'s. For example, you can only enter 18 on the SG but with the UG you can be more precise and enter 18.5
     
  15. Jun 4, 2013 at 11:38 AM
    #15
    127.0.0.1

    127.0.0.1 AKA ::1

    Joined:
    Dec 24, 2012
    Member:
    #93641
    Messages:
    1,693
    Gender:
    Male
    /etc/hosts
    Vehicle:
    2013 NBM AC 4.0 4x4 Auto OR
    well, with any gauge I would want to round down
    to the nearest whole number,

    I'd rather have more gas in the tub than scangauge knows about honestly
     
  16. Jun 5, 2013 at 6:25 AM
    #16
    MowTaco

    MowTaco Well-Known Member

    Joined:
    Sep 9, 2009
    Member:
    #22530
    Messages:
    3,824
    Gender:
    Male
    First Name:
    Matt
    South Dakota
    Vehicle:
    03 GMC Sierra
    Odd. My flashing comes and goes. And if I remember correctly the instant ABS is needed the flashing will turn off while the system is active. BUT I don't have a scangauge/ultragauge I just have a bluetooth dongle plugged into it that broadcasts to my phone (the Torque app for $5 is way better than any OBD-II gauge I've ever seen)
     
  17. Jun 5, 2013 at 6:40 AM
    #17
    127.0.0.1

    127.0.0.1 AKA ::1

    Joined:
    Dec 24, 2012
    Member:
    #93641
    Messages:
    1,693
    Gender:
    Male
    /etc/hosts
    Vehicle:
    2013 NBM AC 4.0 4x4 Auto OR
    see, this is where I will always disagree. but I am an old codger
    when it comes to personal tech devices....

    I am a techie and do tech stuff as a job, way beyond most...bleeding
    edge cyberpolice stuff (LOL :D )...and I guess I could take my job home
    with me with an Android...but when I clock out at 5, I am done with
    tech, and I'd rather grab a wheelbarrow and prybar and move rocks
    or ride mountain bikes when not at work....

    anywho...I will never suck the phone provider corporate teat for a smartphone
    until the bandwidth goes up and the costs down, as in EU

    ---
    so, for now, I have a old-school cell phone and it costs me 20 bucks a month.

    hence, I have to use dedicated OBDII tools....

    but I also have tons of money saved because I don't have a smartphone
    bill....I truly believe it is the biggest waste of money on the planet, fees for
    smartphones...
     
    Last edited: Jun 5, 2013
  18. Aug 11, 2013 at 1:54 PM
    #18
    Fluffymonkey

    Fluffymonkey Token

    Joined:
    Jul 14, 2008
    Member:
    #7932
    Messages:
    2,170
    Gender:
    Male
    First Name:
    Matt
    College Station, TX/ Lawrence, KS
    Vehicle:
    2013 Trd Sport DC, 07 DC sr5
    2007: Avid sliders, 30% front tint, Truxedo low-pro qt tonneu cover, aero turbine 2525 muffler w/ 8'' tip, AR25 Resonator, 16x8 Dick Cepek DC-1 w/ 265/75 Goodyear Wrangler Duratracs, 2010 headlights, ome 884 coils with .5'' top plate spacer, OME sport front shocks, blisten 5100s rear, 2'' aal, locking gas cap, LR ucas, Viper 2-way remote start, afe drop in filter, Rocky locking bike mounts, gear chest, scanguage, pop n lock tailgate lock 2013: most things transferred over from my 07, 5100s @ .85 + eibachs, wheelers progressive aal w/ overload


    How much did the modified cable run you? I plugged my scanguage II into my 2013 a few days ago and every since my VSC and traction control lights on the dash have been going crazy. I unplugged it and all was fine again.
     
  19. Aug 11, 2013 at 2:19 PM
    #19
    BigOly

    BigOly Well-Known Member

    Joined:
    May 3, 2012
    Member:
    #78148
    Messages:
    417
    Gender:
    Male
    Bay Area, NorCal
    Vehicle:
    04 TRD DC V6 SR5 4WD
    The SG folks sent me a modified cable for free after explaining to them my problem. Follow the golden rule while dealing with them and they should treat you the same. Their customer service was superb.
     
  20. Aug 11, 2013 at 3:01 PM
    #20
    Fluffymonkey

    Fluffymonkey Token

    Joined:
    Jul 14, 2008
    Member:
    #7932
    Messages:
    2,170
    Gender:
    Male
    First Name:
    Matt
    College Station, TX/ Lawrence, KS
    Vehicle:
    2013 Trd Sport DC, 07 DC sr5
    2007: Avid sliders, 30% front tint, Truxedo low-pro qt tonneu cover, aero turbine 2525 muffler w/ 8'' tip, AR25 Resonator, 16x8 Dick Cepek DC-1 w/ 265/75 Goodyear Wrangler Duratracs, 2010 headlights, ome 884 coils with .5'' top plate spacer, OME sport front shocks, blisten 5100s rear, 2'' aal, locking gas cap, LR ucas, Viper 2-way remote start, afe drop in filter, Rocky locking bike mounts, gear chest, scanguage, pop n lock tailgate lock 2013: most things transferred over from my 07, 5100s @ .85 + eibachs, wheelers progressive aal w/ overload
    Awesome, I'll give them a call. Thanks a lot for the quick response and help :thumbsup:
     
To Top