1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Water under front floor mat

Discussion in '2nd Gen. Tacomas (2005-2015)' started by shredtacoma, Dec 31, 2010.

  1. Dec 31, 2010 at 6:35 PM
    #1
    shredtacoma

    shredtacoma [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28929
    Messages:
    374
    Gender:
    Male
    First Name:
    Jace
    SOCAL
    Vehicle:
    07 Prerunner Debadged with snugtop
    Camburg lift, ProComp rims, Nitto Terragrappler tires, snugtop, Flowmaster exhaust and Airraid intake
    I have weather tech floor mats and every morning rain or shine there is alot of water soaked into the carpet (only on the passenger side). Has anyone had this issue? Know wut it is? Know how to fix it?


    Thanks
     
  2. Dec 31, 2010 at 6:38 PM
    #2
    surfsupl

    surfsupl Well-Known Member

    Joined:
    Jan 8, 2008
    Member:
    #4161
    Messages:
    8,572
    Gender:
    Male
    First Name:
    Gregg
    WestCoast
    Vehicle:
    I DONT CARE IF IT'S A RE-POST
    Rear Diff Breather~ 5100's ~Fog Light Anytime~Tint~TRD Seat Covers~Weather Tech's~Pioneer H.U.~Lift~Eibach Springs~LED's......blah...blah...blah
    Their is a really good write up about this with pictures that was posted in the last week. Let me search around.
     
  3. Dec 31, 2010 at 6:39 PM
    #3
    surfsupl

    surfsupl Well-Known Member

    Joined:
    Jan 8, 2008
    Member:
    #4161
    Messages:
    8,572
    Gender:
    Male
    First Name:
    Gregg
    WestCoast
    Vehicle:
    I DONT CARE IF IT'S A RE-POST
    Rear Diff Breather~ 5100's ~Fog Light Anytime~Tint~TRD Seat Covers~Weather Tech's~Pioneer H.U.~Lift~Eibach Springs~LED's......blah...blah...blah
  4. Dec 31, 2010 at 6:46 PM
    #4
    05Moose

    05Moose Middle-Aged Member

    Joined:
    Jan 18, 2010
    Member:
    #29613
    Messages:
    2,535
    Gender:
    Male
    First Name:
    Jim
    In the snow (NorCal)
    Vehicle:
    '05 4x4 DC LB SR5 #8 (LSD, Tow Pkg)
    '05 4x4 DC LB SR5 (LSD & Tow Pkg), Timbrens, AAL, 5100s (.85), Owned: 12/3/04 Mods: Fog, Map/Dome Light, Illuminated 4wd Switch, Washable Cabin Air Filter
  5. Dec 31, 2010 at 9:26 PM
    #5
    Gadvan

    Gadvan Well-Known Member

    Joined:
    Aug 14, 2010
    Member:
    #41679
    Messages:
    153
    Gender:
    Male
    cincinnati,ohio
    Vehicle:
    v6 SR5 TRD
    clogged ac drain? sounds like it
     
  6. Dec 31, 2010 at 11:17 PM
    #6
    shredtacoma

    shredtacoma [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28929
    Messages:
    374
    Gender:
    Male
    First Name:
    Jace
    SOCAL
    Vehicle:
    07 Prerunner Debadged with snugtop
    Camburg lift, ProComp rims, Nitto Terragrappler tires, snugtop, Flowmaster exhaust and Airraid intake
    well the thing is i have the weather tech rubber floor mat and there is no water on the floormat but under it
     
  7. Dec 31, 2010 at 11:26 PM
    #7
    lookylookitzadam

    lookylookitzadam Retrofit Club!

    Joined:
    Jul 16, 2009
    Member:
    #19777
    Messages:
    713
    Gender:
    Male
    First Name:
    Adam
    San Diego
    Vehicle:
    07 DC OffRoad
    heater core?
     
  8. Jan 1, 2011 at 12:27 AM
    #8
    shredtacoma

    shredtacoma [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28929
    Messages:
    374
    Gender:
    Male
    First Name:
    Jace
    SOCAL
    Vehicle:
    07 Prerunner Debadged with snugtop
    Camburg lift, ProComp rims, Nitto Terragrappler tires, snugtop, Flowmaster exhaust and Airraid intake
    idk but i need to find out so i can get it fixed
     
  9. Jan 1, 2011 at 12:28 AM
    #9
    lookylookitzadam

    lookylookitzadam Retrofit Club!

    Joined:
    Jul 16, 2009
    Member:
    #19777
    Messages:
    713
    Gender:
    Male
    First Name:
    Adam
    San Diego
    Vehicle:
    07 DC OffRoad
    does it smell like coolant?

    When your car is cool (not right after you drive it) pop the radiator cap off and smell it, then smell the liquid under the mats. If it smells the same, its a leaky heater core.
     
  10. Jan 1, 2011 at 5:34 AM
    #10
    Wattapunk

    Wattapunk Stay lifted my friends !

    Joined:
    Jan 26, 2010
    Member:
    #30098
    Messages:
    1,449
    Gender:
    Male
    First Name:
    Uncle K
    TX
    Vehicle:
    2005 Dbl Cab LB 4x4 TRD
    Toytec CO's, IRONMAN rear leaf pack, All pro front bumper, Body Armor rear bumper, BA steps MB TKO's w/285/75/16 Terra Grapplers, Bakflip tonneau cover, autopage remote start alarm, Ultragauge
    You would also have coolant loss in the radiator, along with a rise in your temp gauge.
     
  11. Jan 1, 2011 at 9:52 AM
    #11
    05Moose

    05Moose Middle-Aged Member

    Joined:
    Jan 18, 2010
    Member:
    #29613
    Messages:
    2,535
    Gender:
    Male
    First Name:
    Jim
    In the snow (NorCal)
    Vehicle:
    '05 4x4 DC LB SR5 #8 (LSD, Tow Pkg)
    '05 4x4 DC LB SR5 (LSD & Tow Pkg), Timbrens, AAL, 5100s (.85), Owned: 12/3/04 Mods: Fog, Map/Dome Light, Illuminated 4wd Switch, Washable Cabin Air Filter
    The clogged drain hose could be the culprit since any leaking would occur on the carpet before it got to your weathertechs. One other thing you should check is the rear floor carpet. There have been a few people with the front driver's side carpet wet underneath and found the leak was in the rear and traveling under the carpet to the front.
     
  12. Jan 1, 2011 at 12:27 PM
    #12
    surfsupl

    surfsupl Well-Known Member

    Joined:
    Jan 8, 2008
    Member:
    #4161
    Messages:
    8,572
    Gender:
    Male
    First Name:
    Gregg
    WestCoast
    Vehicle:
    I DONT CARE IF IT'S A RE-POST
    Rear Diff Breather~ 5100's ~Fog Light Anytime~Tint~TRD Seat Covers~Weather Tech's~Pioneer H.U.~Lift~Eibach Springs~LED's......blah...blah...blah
    How long have you noticed your problem? Recently or since the purchase of the truck?
     
  13. Jan 1, 2011 at 4:33 PM
    #13
    shredtacoma

    shredtacoma [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28929
    Messages:
    374
    Gender:
    Male
    First Name:
    Jace
    SOCAL
    Vehicle:
    07 Prerunner Debadged with snugtop
    Camburg lift, ProComp rims, Nitto Terragrappler tires, snugtop, Flowmaster exhaust and Airraid intake
    but probly like 2-3 months, and my truck is an 07, i took it in for 25000 mile service and told toyota and they didnt know where it was coming from.
     
  14. Jan 1, 2011 at 5:25 PM
    #14
    shredtacoma

    shredtacoma [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28929
    Messages:
    374
    Gender:
    Male
    First Name:
    Jace
    SOCAL
    Vehicle:
    07 Prerunner Debadged with snugtop
    Camburg lift, ProComp rims, Nitto Terragrappler tires, snugtop, Flowmaster exhaust and Airraid intake
  15. Jan 1, 2011 at 5:39 PM
    #15
    KAWAIANIANI

    KAWAIANIANI Well-Known Member

    Joined:
    Mar 3, 2010
    Member:
    #32462
    Messages:
    247
    Gender:
    Male
    First Name:
    Chris
    Vehicle:
    TRD BLACKED OUT
    Weather tech stone deflector, Craven speed stubby antennae,DTLT and rear O2 Sims, URD Y pipe, 40 series flowmaster w/ 3" piping. Urd maf calibrator, TRD supercharger, TRD CAI.
    So is it actually water? Is it coolant? we need more info to help you. Has it been happening since a windshield replacement?
     
  16. Jan 1, 2011 at 5:40 PM
    #16
    surfsupl

    surfsupl Well-Known Member

    Joined:
    Jan 8, 2008
    Member:
    #4161
    Messages:
    8,572
    Gender:
    Male
    First Name:
    Gregg
    WestCoast
    Vehicle:
    I DONT CARE IF IT'S A RE-POST
    Rear Diff Breather~ 5100's ~Fog Light Anytime~Tint~TRD Seat Covers~Weather Tech's~Pioneer H.U.~Lift~Eibach Springs~LED's......blah...blah...blah
    I would remove the carpet then and check the area's where the factory used their sealant on various areas of the body. (kind of looks like a heavy bead of caulking) Sounds maybe like a gradual problem getting worse. Remember,we did have those really heavy rains in SoCal a couple weeks ago.
     
  17. Jan 2, 2011 at 9:06 PM
    #17
    shredtacoma

    shredtacoma [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28929
    Messages:
    374
    Gender:
    Male
    First Name:
    Jace
    SOCAL
    Vehicle:
    07 Prerunner Debadged with snugtop
    Camburg lift, ProComp rims, Nitto Terragrappler tires, snugtop, Flowmaster exhaust and Airraid intake
  18. Jan 2, 2011 at 9:29 PM
    #18
    builthatch

    builthatch MiG-21 superfan

    Joined:
    Nov 25, 2010
    Member:
    #46713
    Messages:
    549
    Gender:
    Male
    First Name:
    Tony Mandarich
    near the ocean, NJ
    Vehicle:
    '11 SSM SR5 6 speed 4x4
    Hella DOT wattage high performance 9003 headlight bulbs, Optilux by Hella XY h10 fog light bulbs, Suntek HP50 tint, AFE Stage II Si intake
    leaking cabin filter, as mentioned above.
     
  19. Jan 2, 2011 at 9:43 PM
    #19
    Taco11

    Taco11 Well-Known Member

    Joined:
    Sep 11, 2010
    Member:
    #43080
    Messages:
    175
    Gender:
    Male
    First Name:
    Chris
    Seattle WA
    How can we help you if you dont check the things we suggest and report back?
     
  20. Jan 3, 2011 at 1:34 AM
    #20
    TRDsport253

    TRDsport253 Well-Known Member

    Joined:
    Nov 15, 2009
    Member:
    #25945
    Messages:
    1,667
    Gender:
    Male
    Fife, Wa
    Vehicle:
    05 PreRunner TRDsport
    TRD Cold air TRD Cat-back
    I have the same problem and its just the passenger side. I have the revised oem all weather mat. It seem like condensation but I don't know for sure. Anyone have this problem please chime in and help.
     
To Top